Home Bug Reports

Ice.Warn.UnknownProperties=0 don't work in 3.2

brianbrian Member brian whitneyOrganization: boulder research and developmentProject: MarketBank ✭✭✭
We are upgrading from 3.1.1 to 3.2 and are now getting unknown property warnings for the first time. I've tried setting Ice.Warn.UnknownProperties=0 in configuration files and on the command line for icegridregistry, icegridnode, and icegridadmin, but to no avail -- i.e. we still get the warnings.

FYI,

Brian

Comments

  • dwaynedwayne St. John's, NewfoundlandMember Dwayne BooneOrganization: ZeroC, Inc.Project: Internet Communications Engine
    What are the warnings you are seeing?
  • brianbrian Member brian whitneyOrganization: boulder research and developmentProject: MarketBank ✭✭✭
    Hi Dwayne,

    This is what we have been getting:

    3/27/07 13:08:18:140 warning: found unknown properties for object adapter 'Robotrade':
    Robotrade.BytesMeter
    Robotrade.Identity

    We have been using this template with past versions that is probably causing these warnings in 3.2:

    <service-template id="ServiceTemplate">
    <parameter name="name"/>
    <parameter name="entry"/>
    <parameter name="identity"/>
    <parameter name="type"/>
    <parameter name="threads" default="50"/>
    <parameter name="bytesMeter" default="off"/>
    <service name="${name}"
    entry="${entry}">
    <adapter name="${service}" endpoints="default">
    <object identity="${identity}" type="${type}"/>
    </adapter>
    <property name="${service}.Identity" value="${service}"/>
    <property name="Conductor.Subscriber.Endpoints" value="tcp"/>
    <property name="${service}.ThreadPool.Size" value="${threads}"/>
    <property name="${service}.BytesMeter" value="${bytesMeter}"/>
    <target name="debug">
    <property name="Ice.Trace.Location" value="1"/>
    <property name="Ice.Trace.Network" value="3"/>
    <property name="Ice.Trace.Protocol" value="1"/>
    <property name="Ice.Warn.Connections" value="1"/>
    </target>
    </service>
  • dwaynedwayne St. John's, NewfoundlandMember Dwayne BooneOrganization: ZeroC, Inc.Project: Internet Communications Engine
    Have you tried adding the property to your service template? ie

    <property name="Ice.Warn.UnknownProperties" value="0"/>
  • brianbrian Member brian whitneyOrganization: boulder research and developmentProject: MarketBank ✭✭✭
    That worked. Thanks, Dwayne.
Sign In or Register to comment.