Does Ice-3.3 and Ice-3.2.1 compatible?

sinofoolsinofool Bochun BaiOrganization: sinofool.comProject: http://sinofool.com/Member ✭✭
I am planning an upgrade from Ice-3.2.1 to Ice-3.3.0 for IceStorm-HA.

Does protocol compatible between Ice-3.3 and Ice-3.2.1?

Can I use different version of icegrid(node/registry/box) together?
Can I use different version of Ice.jar and icegrid(node/registry/box)?

Comments

  • benoitbenoit Rennes, FranceBenoit FoucherOrganization: ZeroC, Inc.Project: IceAdministrators, ZeroC Staff ZeroC Staff
    sinofool wrote: »
    I am planning an upgrade from Ice-3.2.1 to Ice-3.3.0 for IceStorm-HA.

    Does protocol compatible between Ice-3.3 and Ice-3.2.1?

    Yes, the Ice protocol is fully backward compatible.
    Can I use different version of icegrid(node/registry/box) together?

    Yes, IceGrid components are backward compatible starting with Ice 3.2.0 so an IceGrid node from Ice >= 3.2.0 should be able to talk to the IceGrid 3.3.0 registry or vice-versa.
    Can I use different version of Ice.jar and icegrid(node/registry/box)?

    Yes.

    Cheers,
    Benoit.
  • sinofoolsinofool Bochun BaiOrganization: sinofool.comProject: http://sinofool.com/Member ✭✭
    What a great design !
    Thanks a lot.
Sign In or Register to comment.