OSX x32 support question

CryptoCLoverCryptoCLover Member Kutrapal MalikOrganization: CryptoHyndiProject: Client-server app for files exchanging
Hello.

We've been using your awesome framework for years, guys. It's like lovely COM and even better in some cases! Glacier is a pure masterpiece.

The question is: are you planning to support ICE for x32 OSX systems? I've noticed that brew, for example, supports only x64 prebuilt version of your framework. I'am working under the x64 osx, but some guys want to build ICE as x32 binaries / libraries under the x64 system.

Comments

  • xdmxdm ZeroC Staff La Coruña, SpainAdministrators, ZeroC Staff Jose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    Hi,

    You can build i386 binaries by setting the right CXXARCHFLAGS, note that you will also need i386 builds of the third party dependencies.

    Something like this should work to build i386 Ice binaries, providing that third party i386 dependencies has been build.
    make CXXARCHFLAGS="-arch i386"
    


  • CryptoCLoverCryptoCLover Member Kutrapal MalikOrganization: CryptoHyndiProject: Client-server app for files exchanging
    Thank you a lot for the response!

    Does it mean that you are testing ICE as x32 build under OSX and support of possibility of such build will be in every future ICE releases?
    I know that, for example, for FreeBSD there are some patches to build ICE and I am not sure that zeroc supports that patches.
  • xdmxdm ZeroC Staff La Coruña, SpainAdministrators, ZeroC Staff Jose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    As Ice 3.6 we not longer test or support 32 bit builds under OS X. We just support and test x64 build under OS X. See supported platforms
  • CryptoCLoverCryptoCLover Member Kutrapal MalikOrganization: CryptoHyndiProject: Client-server app for files exchanging
    Thank you a lot.

    Good luck in your business!
Sign In or Register to comment.