This forum has been archived. Please start a new discussion on GitHub.

displaying java GUIs on windows using remote SSH invocation

We have been successfully deploying a number of java and c++ IcePack
services on both windows 2000 and Solaris 8 platforms using Ice 1.4 for
over a year now. Up to this point, we have started the icepackregistry,
icepacknode and icepackadmin processes interactively from local bash shells
on windows (cygwin bash) and solaris. Our client gui services are written in
Java and display on both platforms with no problems.

Now, we want to make starting IcePack more convenient by not requiring
the user to start things interactively on various machines. Our goal is to build a
perl script that reads a configuration file for an icepack domain and starts
the registry, local and remote nodes and the admin automatically on all machines
in the domain.

We are using a perl script to start the ice services locally and remotely
(using SSH). Under solaris, in order to get the Java guis to display remotely,
we have had to add setting the X11 display authentication
( xhost + ) and the DISPLAY variable to the remote shell that starts an
icepack service.

However, if the perl script starts icepacknode remotely
using openSSH to a windows 2000 machine, nothing is displayed
from the java service. All indications from Ice show
that the application is running, yet all we see are the
java and ice (icepacknode, icebox) processes - the java
GUI does not display.

We have tried icepacknode and icepackregistry with and with
out the daemon option with no noticeable effect. We
have also run an X server on the windows 2000 system
with no success.

Does anyone have any ideas on might what be happening to our Java GUIs when
using SSH in a perl script to start icepacknode remotely on a Win2K box?



  • Hey guys,

    I'm really stuck with this java gui display problem and would appreciate any ideas.

    Is there any more information I can pass along to help you?

  • I'm sorry, but I can't really help. I suspect though that this has little to do with IcePack. What I would do is take IcePack out of the picture first and write a small program that launches your application on the remote host. A simple shell script should be enough. If you then see the same problems, you will have at least simplified the problem. If not, then we can start to look at any differences in the way processes are created by IcePack and your program in order to help narrow this down.


  • Michi,

    You are right. This was not an IcePack problem, but we are still having a very difficult time trying to remotely start IcePack nodes on a PC for various reasons. Turns out that just trying to fire up a simple Java gui remotely using ssh does not work. We tried the kludge of using that Windows "at" command, but it requires the thing being started to be a Windows process and we are using cygwin bash scripts.

    So we have a more general question which is: Does ZeroC have any tools that would facilitate our goal as described in the 2nd paragraph in John's original message?

    I would assume we are not the only ones using Ice and trying to automate this process of starting up a domain on various platforms. Have you heard about any of your client's solutions for doing this?

    Any general suggestions or comments on accomplishing our goal here?

    Thanks again,

  • Sorry we don't have any tools that would do this. Off-hand, I don't know how you could best do what you want. A quick web search revealed the following. Maybe one of those will be useful.