Home Help Center

Glacier2 and callback questions?

rhochmuthrhochmuth Member Roland HochmuthOrganization: HPProject: RGS ✭✭
I'm trying to implement Glacier2. I beleive that I have done everything. However, on the callbacks, the connection appears to be directly back to the client. The out-bound connections appear to be using the glacier2 router. I'm using netstat and other tools to look at the connections. I'm just wondering what I might have done incorrectly.

I've done the following:

1. Created the router session.

2. Created a category for the router.

3. On the glacier2 router I've set the glacier2 client and server end-points.

4. On the client I've set the default router.

Any suggestions on what might be missing or mis-configured?

I've run the demo callback example and that seems to work, only establishing one connection. So the problem is in my program.

More stuff about my program.

I tried setting the "Callback.Client.Router=Glacer2/router", but I didn't think I needed too do this, but this is what is done the the callback demo program. Is this really necessary if using one object adapter and Ice.Default.Router is set?

I'm also wondering if the Server needs to use Ice 2.0.0 too. Currently, my app is using Ice 1.5.0 on the Server side. Do I need to upgrade both the client and server?

My programs are running on the same network. No private or loopback interfaces, just different systems. Should I run the "Server" on a private or loopback interface? I guess my thought is that the routing might only occur through glacier2 if the more direct route (server directly back to client) fails thus bypassing glacier if a more efficient path is possible. I guess I should just try this.

My app uses both tcp and ssl connections simultaneously on both the client and server. So I set-up the glacier2 server endpoints with both tcp and ssl,.

Regards --Roland

Comments

  • marcmarc FloridaAdministrators, ZeroC Staff Marc LaukienOrganization: ZeroC, Inc.Project: The Internet Communications Engine ZeroC Staff
    The most likely reason is that you did not add a router to your object adapter with ObjectAdapter::addRouter(), or with configuration parameters. Setting Ice.Default.Router alone is not enough. This is for the client side behavior only.

    Your server does not need to be Ice 2.0. Glacier2 is completely transparent for the server.
  • rhochmuthrhochmuth Member Roland HochmuthOrganization: HPProject: RGS ✭✭
    Wow, That was fast, and that was it. All is working. Thanks for the help! --Roland
Sign In or Register to comment.