Home Help Center

Test fail

I've Redhat 7.2 and gcc 3.2.3
I have successfully compiled Ice. But when I run the tests, it fails:

make test

*** running tests in ./test/IceUtil/thread:

starting client... ok
running thread create test... ok
running thread detach test... test failed with exit status 1
make: *** [test] Error 1

How can I know the reason? How can I enable logs?
Thanks in advance.

Comments

  • mesmes CaliforniaAdministrators, ZeroC Staff Mark SpruiellOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    Change to the test/IceUtil/thread directory and run

    $ ./client

    Please let us know what you find out.

    Also, can you provide the output of 'gcc -v'?

    - Mark
  • Here are the information you requested (while running ./client I could see a sequence of numbers running on the console)

    [[email protected] thread]$ ./client
    running thread create test... ok
    running thread detach test... Aborted
    [[email protected] thread]$ gcc --version
    gcc (GCC) 3.2.3
    Copyright (C) 2002 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions. There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
  • mesmes CaliforniaAdministrators, ZeroC Staff Mark SpruiellOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    What does 'gcc -v' report?

    On my system (RH 7.1) I get the following:

    $ gcc -v
    Reading specs from /opt/gcc-3.2.3/lib/gcc-lib/i686-pc-linux-gnu/3.2.3/specs
    Configured with: ../configure --prefix=/opt/gcc-3.2.3 --enable-threads
    Thread model: posix
    gcc version 3.2.3
  • Despite a number of problemas with gcc 3.2.3, I decided to come back to my old stable version of gcc 3.2
    Now I'm compiling again, disabled Unicode, and this is the next error a have encountered:

    c++ -L../../lib -o ../../bin/icepatchclient Client.o -lIcePatch -lGlacier -lIceSSL -lIce -ldl -lbz2 -lIceUtil -lpthread -luuid -lssl -lcrypto
    ../../lib/libIcePatch.so: undefined reference to `std::basic_istream<char, std::char_traints<char> >::seekg(std::fpos<__mbstate_t>)'
    collect2: ld returned 1 exit status
    make[2]: *** [../../bin/icepatchclient] Error 1

    Here are more info:
    [[email protected] Ice-1.0.1]$ gcc -v
    Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/3.2/specs
    Configured with: ../configure --prefix=/usr --infodir=/usr/info --mandir=/usr/man --enable-shared --enable-threads=posix --enable-languages=c,c++,f77,gcov,java,objc --enable-long-long --enable-multilib --with-gnu-as --with-gnu-ld --with-system-zlib --with-slibdir=/lib --without-x i386-redhat-linux
    Thread model: posix
    gcc version 3.2

    [[email protected] c++]$ rpm -qa|grep c++
    libstdc++-3.2-1
    libstdc++-2.96-98
    gcc-c++-3.2-1
    libstdc++-devel-3.2-1

    Any ideas?
    Best Regards. Diego
  • mesmes CaliforniaAdministrators, ZeroC Staff Mark SpruiellOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    I too recently discovered problems with GCC 3.2.3 and have since reverted to 3.2.

    I'm afraid I don't have any good ideas. Have you tried building GCC 3.2 from source yourself?

    If you do build GCC 3.2 yourself, don't forget to update your PATH and LD_LIBRARY_PATH accordingly.
  • The function seekg is the unique function that isn't find. So I disabled IcePatch, and the rest of the packages builds and tests successfully.
    I'll try to find why this definition is the only error during the building.

    Best regards and thanks. Diego.
Sign In or Register to comment.