This forum has been archived. Please start a new discussion on GitHub.

icepackregistry start service - cannot find the path specified

I get this error in the event log when I try to start the icepack registry as a service:
.\PropertiesI.cpp:559: Ice::SyscallException:
syscall exception: The system cannot find the path specified.

C:\Program Files\qim\\bin>icepackregistry
--start icepackregistry --Ice.Config="C:\Program Files\qim\
Service start pending.
Service failed to start.
Current state: 1
Exit code: 1
Service specific exit code: 0
Check point: 0
Wait hint: 0

Here are the contents of my config file:

Ice.Default.Locator=IcePack/Locator:default -p 12004

#IcePack.Registry.Client.Endpoints=default -p 12004
IcePack.Registry.Client.Endpoints=default -p 11000 -h


It works when I use the same arguments but dont try to start as a service, ie, just run icepackregistry without the --start servicename arg.


  • mes
    mes California
    The most likely reason for the exception is the service is unable to open the configuration file you specified with the --Ice.Config option. If the executable starts correctly when not running as a service, then the configuration file's pathname is probably correct, and therefore I'll bet that the service does not have permission to access the configuration file.

    To confirm whether this is the case, you can copy the configuration file to the root directory (C:\) and try starting the service again with the new pathname. Of course, you may encounter similar problems if the registry is unable to access its database directories, etc.

    Another alternative is to use the Services control panel to edit the icepackregistry properties so that it starts under your account instead of the Local System account.

    Take care,
    - Mark
  • Thanks for the help Mark.

    I tried both. I moved the config file to the root of c:/ and got the same error, although now for some reason it is not writing to the event log. I also tried changing the login for the service to the domain admin account, but this did not work, I still get an error, although now it has stopped logging to the even log.
  • I resolved this by installing Ice v 2.1.0, I was using v 2.0.0 before. I was not aware of any issues specific to this service starting/stopping stuff that were fixed in 2.1.0, but it works now.
  • mes
    mes California
    I'm glad to hear you've resolved the problem. Note that the most recent release (2.1.2) contains additional fixes for Windows services.

    - Mark