Use spaces instead of tabs

Edward BishopEdward Bishop Member EdwardOrganization: SonyProject: Automated Test ✭✭
I noticed, because the indentation was all wrong in my editor,
that some of your source code uses tabs instead of spaces.
I recommend spaces instead of tabs. Most editors/IDEs can be
configured to do that.

Comments

  • ffmpeg4nmmffmpeg4nmm Member Smart SongOrganization: fastreaming network multimedia Ltd.Project: CDMA
    I strongly support this idea!
    :rolleyes:
  • michimichi Member Michi HenningOrganization: Triodia TechnologiesProject: I have a passing interest in Ice :-) ✭✭✭
    It's not impossible to do, but extra work for us to police this all the time. I suggest piping the source through "expand -t8". That will do the job nicely :)

    Also, for Visual Studio, you can set the indent level to 4, and leave the tab setting at 8, and the source will display correctly.

    Cheers,

    Michi.
  • Edward BishopEdward Bishop Member EdwardOrganization: SonyProject: Automated Test ✭✭
    Hi Michi,

    My current project uses source from multiple sources, including Ice. It doesn't make sense for me to change my IDE settings depending on where I am in the call stack!

    Also, I'm not sure what you mean by "police all the time". It's your source code, presumably you can keep it TAB-free!

    All the best,
    Edward
  • marcmarc FloridaAdministrators, ZeroC Staff Marc LaukienOrganization: ZeroC, Inc.Project: The Internet Communications Engine ZeroC Staff
    Please see this thread. (I don't know yet when we will switch--it's not exactly a high priority issue...)
  • Edward BishopEdward Bishop Member EdwardOrganization: SonyProject: Automated Test ✭✭
    That's great! Just to be clear though, it isn't just the generated code that I have trouble reading (in fact I don't expect that to be readable), it is the Ice source code itself.

    All the best,
    Edward
Sign In or Register to comment.