Home Help Center

IceGrid migration issue: icegridadmin can't reach registry

brianbrian Member brian whitneyOrganization: boulder research and developmentProject: MarketBank ✭✭✭
We have been using IcePack successfully for over 2 years now and are trying to migrate to IceGrid in 3.0. We have read the IceGrid chapter in the manual and the migration article in Ice Connections. We are now trying to apply the same sequence of commands we used with IcePack to IceGrid to start a registry, node, and app on a single machine. We run this same sequence using IcePack in 1.4 and it works fine as it has for a very long time. However, when we run icegridadmin in the 3rd step below it can't reach the registry.

1) Here is the first step (successful):

icegridregistry --Ice.Config=iceGridRegistry.cfg --IceGrid.Registry.Data=registry
icegridregistry: warning: administrative endpoints `IceGrid.Registry.Admin.Endpoints' enabled (IcePack outputs this warning too)

Here is iceGridRegistry.cfg:

Ice.Default.Locator=IceGrid/Locator:default -p 12000 -h proteus
IceGrid.Registry.DefaultTemplates=./Templates.xml
IceGrid.Registry.Client.Endpoints=default -p 12000 -h proteus
IceGrid.Registry.Server.Endpoints=default
IceGrid.Registry.Internal.Endpoints=default
IceGrid.Registry.Admin.Endpoints=default
Ice.Trace.Location=0
Ice.Trace.Retry=0
Ice.ThreadPool.Server.Size=10
Ice.Warn.Leaks=1

2) Now we run icegridnode (successful):

icegridnode --Ice.Config=iceGridNode.cfg --IceGrid.Node.Data=node --IceGrid.Node.Output=LOGS --IceGrid.Node.Name=proteus --Ice.Default.Locator="IceGrid/Locator:default -p 12000 -h proteus" --warn

Here is iceGridNode.cfg:

IceGrid.Node.Endpoints=default
IceGrid.Node.WaitTime=30
IceGrid.Node.CollocateRegistry=0
IceGrid.Node.RedirectErrToOut=1

Ice.Trace.Location=0
Ice.Trace.Retry=0
Ice.Trace.GC=0
IceGrid.Node.Trace.Activator=0
IceGrid.Node.Trace.Adapter=0
IceGrid.Node.Trace.Server=0

Ice.ThreadPool.Server.Size=10
Ice.Warn.Leaks=1

3) icegridadmin (fails):

icegridadmin --Ice.Config=iceGridNode.cfg --Ice.Default.Locator="IceGrid/Locator:default -p 12000 -h proteus" -e "application add Application.xml"

error: couldn't reach the IceGrid registry:Network.cpp:693:Ice::ConnectionRefusedException:
connection refused: Connection refused

Here is Application.xml:

<icegrid>
<application name="MarketBank" import-default-templates="true"/>
</icegrid>


Since this works using IcePack, we are either doing something very dumb that we are just missing here or there is some requirement using IceGrid that did not exist with IcePack that we missed in the docs.

Any help would be greatly appreciated.

Thanks,
Brian

Comments

  • marcmarc FloridaAdministrators, ZeroC Staff Marc LaukienOrganization: ZeroC, Inc.Project: The Internet Communications Engine ZeroC Staff
    I'm afraid this goes beyond the free support we can give here on these forums (we have already answered many of your other questions). Please contact us at [email protected] for a support contract.
Sign In or Register to comment.