Home Help Center

latest patch by michi

xdmxdm La Coruña, SpainAdministrators, ZeroC Staff Jose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
latest patch submit by michi say
the attached patch fixes a problem with the class garbage collector in Ice for C++ that can result in double-deletion of class instances.

Note that the patch is not binary compatible, so you need to recompile client/server code after recompiling Ice.

This patch will be included in the 3.1 release.

I need install this pathc with Ice-3.0.1? are other patch for ice 3.0.0 not present in Ice-3.0.1 for java or c++

thanks all you

Comments

  • dwaynedwayne St. John's, NewfoundlandMember Dwayne BooneOrganization: ZeroC, Inc.Project: Internet Communications Engine
    Yes, you need to install this patch for Ice 3.0.1. Since we ensure that all patch releases are binary compatible with the previous version, we did not include this change in 3.0.1. As Michi stated it will be included in the 3.1 release.

    I am not aware of any other binary incompatible patches that did not make it into the 3.0.1 release.

    Regards.
    Dwayne
  • benoitbenoit Rennes, FranceAdministrators, ZeroC Staff Benoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    This [thread=1933]IceGrid patch[/thread] wasn't included into Ice 3.0.1 as well since it would have potentially broken existing configuration. It will be included in Ice 3.1.0.

    Cheers,
    Benoit.
  • xdmxdm La Coruña, SpainAdministrators, ZeroC Staff Jose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    Patch broken Ice-3.0.1 compilation

    Hi

    i apply this tow pathcs but same are skiped and them compilation is broken

    Patch ouput
    [email protected] /opt/src/Ice-3.0.1 $ patch -p0 < IceGrid-Path-by-Beniot.txt
    patching file src/IceBox/ServiceManagerI.cpp
    Hunk #1 FAILED at 7.
    Hunk #2 succeeded at 208 (offset 1 line).
    1 out of 2 hunks FAILED -- saving rejects to file src/IceBox/ServiceManagerI.cpp.rej
    patching file src/IceGrid/ServerI.cpp
    Hunk #1 FAILED at 1787.
    1 out of 1 hunk FAILED -- saving rejects to file src/IceGrid/ServerI.cpp.rej
    [email protected] /opt/src/Ice-3.0.1 $ patch -p0 < IceGrid-patch-by-Michi.txt
    patching file include/Ice/GC.h
    patching file include/Ice/GCShared.h
    patching file src/Ice/GC.cpp
    Reversed (or previously applied) patch detected!  Assume -R? [n] n
    Apply anyway? [n]
    Skipping patch.
    6 out of 6 hunks ignored -- saving rejects to file src/Ice/GC.cpp.rej
    patching file src/Ice/GCShared.cpp
    patching file src/slice2cpp/Gen.cpp
    Hunk #1 succeeded at 3156 (offset -5 lines).
    Hunk #2 succeeded at 3222 (offset -5 lines).
    Hunk #3 succeeded at 3291 (offset -5 lines).
    Hunk #4 succeeded at 3345 (offset -5 lines).
    patching file test/Ice/gc/Client.cpp
    

    Compilation error
    c++ -c -I.. -I../../include  -DICE_BOX_API_EXPORTS -I/opt/db/include   -ftemplate-depth-128 -Wall -D_REENTRANT -fPIC -g ServiceManagerI.cpp
    ServiceManagerI.cpp: In member function `void
       IceBox::ServiceManagerI::load(const std::string&, const std::string&)':
    ServiceManagerI.cpp:210: error: no class template named `Options' in `IceUtil'
    make[2]: *** [ServiceManagerI.o] Error 1
    make[2]: Leaving directory `/opt/src/Ice-3.0.1/src/IceBox'
    make[1]: *** [all] Error 1
    make[1]: Leaving directory `/opt/src/Ice-3.0.1/src'
    make: *** [all] Error 1
    

    Compiler: gcc version 3.3.6 (Gentoo 3.3.6, ssp-3.3.6-1.0, pie-8.7.8)
    Db version:4.3.29

    I have Ice-3.0.0 installed in this machine with all released patchs. is better update to Ice-3.0.1? when you relase a new patch for 3.0.1 is this compatible with Ice-3.0.0

    thanks again
  • benoitbenoit Rennes, FranceAdministrators, ZeroC Staff Benoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    xdm wrote:
    I have Ice-3.0.0 installed in this machine with all released patchs. is better update to Ice-3.0.1? when you relase a new patch for 3.0.1 is this compatible with Ice-3.0.0

    thanks again

    The patches for 3.0.0 aren't compatible with 3.0.1. We will post new ones for 3.0.1 soon. The best is to upgrade to 3.0.1 and eventually apply these patches if you need them. Patches released for 3.0.1 won't necessarily be compatible with Ice 3.0.0.

    Cheers,
    Benoit.
  • benoitbenoit Rennes, FranceAdministrators, ZeroC Staff Benoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Hello Jose,

    You'll find the patches [thread=2041]here[/thread] and [thread=2042]here[/thread].

    Cheers,
    Benoit.
Sign In or Register to comment.