Home Bug Reports

PHP5 Strict warnings

When calling Ice_LoadProfile('foo'); in PHP 5.1.1 (Ice and IcePHP 3.0.1) with error_reporting set to strict, it generates several warnings. All the warnings concern the use of the 'var' keyword in PHP, which is deprecated and needs to be substituted by one of the 'public', 'private' or 'protected' keywords.

Example of the error report:
(2048) "var: Deprecated. Please use the public/private/protected modifiers" at __core on line 32
(2048) "var: Deprecated. Please use the public/private/protected modifiers" at __core on line 66
(2048) "var: Deprecated. Please use the public/private/protected modifiers" at __core on line 67
(2048) "var: Deprecated. Please use the public/private/protected modifiers" at __core on line 68
(2048) "var: Deprecated. Please use the public/private/protected modifiers" at __core on line 108
(2048) "var: Deprecated. Please use the public/private/protected modifiers" at __core on line 133
(2048) "var: Deprecated. Please use the public/private/protected modifiers" at __core on line 157
(2048) "var: Deprecated. Please use the public/private/protected modifiers" at __slice on line 11
(2048) "var: Deprecated. Please use the public/private/protected modifiers" at __slice on line 28
(2048) "var: Deprecated. Please use the public/private/protected modifiers" at __slice on line 29

Is there any way to solve this from my side, or is this a problem in Ice?

Comments

  • mesmes CaliforniaAdministrators, ZeroC Staff Mark SpruiellOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    Hi,

    This is a problem in Ice; more specifically, in the PHP code that we generate internally. We'll fix this for the next release.

    Thanks,
    - Mark
Sign In or Register to comment.