Home Bug Reports

Ice 3.1.0 requires Ant 1.6.3+

Andreas SchererAndreas Scherer Member Andreas SchererOrganization: Private Linux SiteProject: Evaluating Ice-C++, Ice-Python, Ice-Ruby ✭✭
Cheers to ZeroC for the new release!

After extracting the source RPM, commenting the C# stuff, and running rpmbuild, I receive a set of installation RPM files. These are used to update the installation on OpenSUSE 10.0. Now I am in the process of updating the modifications I applied to some of the demo codes.

The C++ version of demo/book/printer is fine.

The Java version of demoj/book/printer hickups on "ant", because OpenSUSE 10.0 ships with ant -version 1.6.2, which does not support the "else" attribute. In order to overcome this problem, I edit /usr/share/doc/Ice-3.1.0/config/common.xml, line 215, and remove the "else" stuff. Now "ant build.xml" runs through, and the Client/Server communication works fine. I'd rather /not/ suggest to make ice.spec require ant >= 1.6.3, because I haven't found a suitable ant-RPM for OSS yet.

P.S.: The same is true for my virtual Win2k installation with Eclipse 3.0.

The Python version of demopy/hello (and the printer demo from the manual) is fine.

Take care
Sign In or Register to comment.