ACM=0 didn't turn off ACM

We have developed a distributed agent architecture using the IceStorm
publish-subscribe scheme. Each agent publishes and subscribes to
multiple topics. Opening and closing connections during run time seems
to cause delays in data transfer. For that reason, we have tried to
turn off ACM, putting into our configuration files the following lines:

#Server ACM
Ice.ACM.Server=0

#Client ACM
Ice.ACM.Client=0

We still see connections being closed (on the server with tracing turned
on) when running our distributed system with this configuration. Is
there a way to force all connections to stay open?
We still see following message:
[ Network: shutting down tcp connection for writing
local address = 168.233.69.68:3085
remote address = 168.233.69.79:7888 ]
[ Network: closing tcp connection
local address = 168.233.69.68:3085
remote address = 168.233.69.79:7888 ]

We are using Ice version 3.0.1. on Windows XP.

Any help with this problem is greatly appreciated.

Comments

  • matthewmatthew NL, CanadaMember Matthew NewhookOrganization: ZeroC, Inc.Project: Internet Communications Engine ✭✭✭
    Server side ACM is disabled by default so I doubt that the connection is being closed by ACM on the server side. Are you sure that the connection is not being closed by the peer?
  • cloudstarcloudstar Member
    Matthew,

    Thank you. By peer, Do you mean another client closed the connection?
  • matthewmatthew NL, CanadaMember Matthew NewhookOrganization: ZeroC, Inc.Project: Internet Communications Engine ✭✭✭
    Yes, perhaps the client using IceStorm is closing the connection and not IceStorm itself.
Sign In or Register to comment.