Home Help Center

problem with IceGrid example

bdkbdk Member Bruce KarshOrganization: Wink Technologies, IncProject: Wink People Search Engine
In the manual (page 1056) they show indirect proxies like

In my descripor file, I define a server id and an adapter name and try to
use a proxy like
.

It fails with a "no object adapter with id servername.adaptername" error.

But when I use a proxy like
, it succeeds.

Is the manual correct about the syntax
?
I can't find any mention of this syntax anywhere else in the manual. Is there some trick to making it work?

I'm running version 3.1.0.

Comments

  • benoitbenoit Rennes, FranceAdministrators, ZeroC Staff Benoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Hi,

    The manual is correct, an indirect proxy has the following syntax:identity @ adapterId. The adapter id is different from the adapter name. Adapter ids are configured with the "id" attribute of the adapter XML element in the descriptor and if this "id" attribute isn't specified explicitly the default value is "<server id>.<adapter name>".

    See the documention for the adapter element in the Ice manual (section 36.14.1) for more information.

    I don't know why it doesn't work for you, could you post the XML descriptor of your server?

    Cheers,
    Benoit.
  • benoitbenoit Rennes, FranceAdministrators, ZeroC Staff Benoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Btw, could you please set your signature? See this [thread=1697]thread[/thread] for more information on how to set it.

    Thanks,

    Benoit.
  • bdkbdk Member Bruce KarshOrganization: Wink Technologies, IncProject: Wink People Search Engine
    OK, I see what the problem was. I had set both the name and the id - both to the same value. When I set the id, that overrode the default id. When I got rid of the explicit setting of the id, it all worked.

    Thanks for the help.
Sign In or Register to comment.