Home Help Center

icepackregistry --Ice.Config=config

catalincatalin Member ✭✭

I am using ICE 1.1.0 on RedHat 9.0.

I am learning how to write location transparent application with ICE. I have read most of the ICE documentation but of course you only know it when you try it out. So, following the instructions in section 18.5.7, page 492, I have created a file called "config" with the following content:
IcePack.Registry.Client.Endpoints=default -p 12000

Then I created a directory "db". However, when issuing the
icepackregistry --Ice.Config=config

command, I get the following output, and the icepackregistry application seems to go into an eternal loop:
[[email protected]lhost dacapo]$ icepackregistry --Ice.Config=config
icepackregistry: warning: internal endpoints `IcePack.Registry.Internal.Endpoints' disabled
icepackregistry: warning: administrative endpoints `IcePack.Registry.Admin.Endpoints' enabled

I have to kill it with Ctr+C in order to get my command line back. I am afraid this isn't the right behaviour. Can anyone tell me what is wrong? Have I registered my endpoints by now, or did the registration fail? Should I just wait for the icepackregistry application to return?



  • benoitbenoit Rennes, FranceAdministrators, ZeroC Staff Benoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff

    That's the expected behavior. The IcePack registry server will stay in the foreground except if you start it in the background or as a daemon. It will listen for requests on the configured endpoints.

    The following warning:
    icepackregistry: warning: internal endpoints `IcePack.Registry.Internal.Endpoints' disabled

    means that the IcePack registry internal endpoints are not configured. These internal endpoints are usefull when you use IcePack nodes. If you don't use any IcePack nodes yet, you can ignore the warning.

    And this one:
    icepackregistry: warning: administrative endpoints `IcePack.Registry.Admin.Endpoints' enabled

    is just to warn you that the administrative endpoints are enabled and that it might be a securiity risk if these endpoints are accessible to the world.

    You can disable these warnings by passing the --nowarn command line option to the registry.

    Let us know if this doesn't answer your questions!

Sign In or Register to comment.