Home Help Center

Solaris 8 or 10

Has anyone gotten ice to run on Solaris 8 or 10. The documentation states only Solaris 9. We were unable to get it to work on Solaris 8 and want to see if efforts to get it to work on Solaris 10 is worthwhile.

Any help?

Comments

  • alexmalexm Member Eskinder Alex MesfinOrganization: Medtronic, Inc.Project: www.medtronic.com
    dgdillaman wrote:
    Has anyone gotten ice to run on Solaris 8 or 10. The documentation states only Solaris 9. We were unable to get it to work on Solaris 8 and want to see if efforts to get it to work on Solaris 10 is worthwhile.

    Any help?
    on Solaris 8 all needed libraries to compile Ice is not readly available, you must compile it and install it befor, just to mention few:
    bzip
    db4 ..ect and their dependence.
  • failysfailys Member
    We ICE-3.1.0 with Solaris 10 quite extensively at our shop, although we do use Sun Studio 10 and no gcc, which probably helps.
    We also managed to get the above version of ICE built on Solaris 8 as well, but we found we couldn't use a version of CC any less than 5.3.

    The main suggestions I would make if you are going to build ICE from sources are to use the 3rd party sources, where possible, as you hit problems with some of the Sun freeware versions of the ICE dependencies.

    You might also need to make a minor source code modification to the ICE sources as well, this is described in:
    http://www.zeroc.com/vbulletin/showthread.php?t=1861

    Hope this helps,

    Shamal
  • bernardbernard Jupiter, FLAdministrators, ZeroC Staff Bernard NormierOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    failys wrote:
    You might also need to make a minor source code modification to the ICE sources as well, this is described in:
    http://www.zeroc.com/vbulletin/showthread.php?t=1861

    The Ice source code was fixed some time ago. I expect Ice 3.1.1 (and later) to build without any modification on Solaris 10.

    Bernard
Sign In or Register to comment.