Home Help Center

ICE-EJ and the first ICE_MIDlet (with Eclipse)

albertodsalbertods Member Alberto Della SantinaOrganization: University of Pisa - department of IT EngineeringProject: Mobile remote controller ✭✭
Hi all,
I've tried to write my first ICE MIDlet with the help of Eclipse. It's the ClientMIDlet included in the package of the Ice-EJ, inserted in a new MIDlet project with Eclipse (I imported also the Demo's files).

Everything seems right (the inclusion, the build path)... and I get no error from the building phase.

The problem occurs when I try to run it with a J2Me emulator included in the Nokia SDK, this is the message error:
java.lang.NoClassDefFoundError: Ice/Util

I'm sure to have properly included the IceE.jar, both here (as you can see) and in the general CLASSPATH (not the Eclipse's one).


I cannot figure out what the problem could be...


I would appreciate any help


Regards


Alberto

Comments

  • marcmarc FloridaAdministrators, ZeroC Staff Marc LaukienOrganization: ZeroC, Inc.Project: The Internet Communications Engine ZeroC Staff
    I'm sorry, but providing support for Ice-E with the Nokia SDK is out of the scope of the free support we can offer here in these forums. For commercial support services, please contact us at [email protected].
  • albertodsalbertods Member Alberto Della SantinaOrganization: University of Pisa - department of IT EngineeringProject: Mobile remote controller ✭✭
    I chose the Nokia emulator just to use an emulator, but this error persists even with the standard one.

    Could you plese give me any hints to solve this problem?
  • marcmarc FloridaAdministrators, ZeroC Staff Marc LaukienOrganization: ZeroC, Inc.Project: The Internet Communications Engine ZeroC Staff
    What do you mean with "the standard one"?

    Also note that we do not use Eclipse at ZeroC, so we cannot offer you any assistance in setting up Eclipse projects.
  • albertodsalbertods Member Alberto Della SantinaOrganization: University of Pisa - department of IT EngineeringProject: Mobile remote controller ✭✭
    The one included with EclipseME...


    Even if you don't use Eclipse, would you be so kind to explain me the reason for this error?
    Is it just a matter of bad inclusion?



    Alberto
  • marcmarc FloridaAdministrators, ZeroC Staff Marc LaukienOrganization: ZeroC, Inc.Project: The Internet Communications Engine ZeroC Staff
    I'm sorry, but I do not know what this error means. Java doesn't have any classes with a '/'. There is a class Ice.Util, but there is no such thing as a class Ice/Util.

    We can help you if you run your Ice-E for Java application with a regular JDK (not J2ME). Everything else (emulators such as the Nokia one, the one included in EclipseME, or Sun's WTK, or running Ice-E on embedded devices) is out of the scope of the support we can offer here in these forums.
  • albertodsalbertods Member Alberto Della SantinaOrganization: University of Pisa - department of IT EngineeringProject: Mobile remote controller ✭✭
    Problem solved

    I got it: I've just packed only the file Ice/Util.class into a jar file and then I import it separately in my Eclipse (J2ME) project.

    As I said in the prevous post, like all the sources of Ice-EJ, the file Util.java have been initially cleared of the function "finalize()" as well.

    :D :cool:

    Regards


    Alberto
Sign In or Register to comment.