Problem executing IceJ

fgarciafgarcia Member Fernando García GómezOrganization: Recreativos Franco S.A.Project: SLUG ✭✭
Hi,
I have been developing aplications with Ice in C++, and now I am trying to use java with eclipse in Linux instead of C++. I hadn't problems with the installation, and the application I am now developing compile perfectly, but when I try to execute it, it throws this exception:
> java.lang.NoClassDefFoundError: IceStorm/NoSuchTopic: Ice/UserException

If I comment the code using IceStorm, then I get this exception:
> java.lang.NoClassDefFoundError: Ice/Object

or the same, but with Ice/Util instead of Ice/Object

I have added the external jar and all the configuration of the buildpath seems to be right, so I don't know what is happening.

Do you have any idea?

Thanks for your time

Comments

  • davidcr1983davidcr1983 Member David VallejoOrganization: University of Castilla-La Mancha (Spain)Project: Intelligent Surveillance System ✭✭
    Hello!

    Have you established the classpath including the directory of the generated code and the externals .jar when you run your application?

    In my case, I use the following command included in my Makefile:

    java -classpath classes/:/usr/share/java/Ice.jar Agent

    Regards.
  • fgarciafgarcia Member Fernando García GómezOrganization: Recreativos Franco S.A.Project: SLUG ✭✭
    Hi David,
    yes I have included all the necessary .jar files in the eclipse project, I am using IceEJ show I have included /usr/share/java/IceE-1.1.0.jar. The problem is that it seems to recognize all the paths because I haven't problems during the compilation, the problems appears at the execution.

    Thanks (gracias)
Sign In or Register to comment.