Home Comments

Ice 3.2b release

Andreas SchererAndreas Scherer Member Andreas SchererOrganization: Private Linux SiteProject: Evaluating Ice-C++, Ice-Python, Ice-Ruby ✭✭
Dear ZeroC team:

After three hours of playing with the latest (beta) release, I can say: Congratulations!

I'm still running OpenSUSE 10.0, g++ 4.0.2, ruby 1.8.2, java 1.5.0.

After commenting the CS stuff in the rpm spec file, I created eight rpms and updated the installation without problems (rpm -iU ice-*3.2b*) . Then I edited /etc/bash.bashrc.local (CLASSPATH, PYTHONPATH, RUBYLIB, LD_LIBRARY_PATH).

The 'demo/book/printer' demo ran out-of-the-box, also a weird combination of 'demoj/book/printer/Server.java' (I had to hack 'common.xml') and 'demorb/book/printer/Client.rb'. :)

And after modifying the signatur of the 'sayHello' member function, even my QtClient.rb runs fine. See attachment.

Excellent stuff. Thank you very much!

Andreas

Comments

  • beaglesbeagles Member Brent EaglesOrganization: Eagles Technologies IncProject: Asterisk SCF ✭✭✭
    Hi Andreas,

    What kind of change did you need to make to common.xml?

    Cheers,

    Brent
  • Andreas SchererAndreas Scherer Member Andreas SchererOrganization: Private Linux SiteProject: Evaluating Ice-C++, Ice-Python, Ice-Ruby ✭✭
    Hello Brent,

    The version of ant on my system (Apache Ant version 1.6.2) does not like the "else" constructs in common.xml:
    Class org.apache.tools.ant.taskdefs.ConditionTask doesn't support the "else" attribute.
    See the attached unified diff. I simply remove these things to make it match my preferences.

    Take care,
    Andreas
  • dwaynedwayne St. John's, NewfoundlandMember Dwayne BooneOrganization: ZeroC, Inc.Project: Internet Communications Engine
    Hello Brent,

    The version of ant on my system (Apache Ant version 1.6.2) does not like the "else" constructs in common.xml:

    Yes, that is expected. IceJ requires ant 1.6.3 or greater.

    Regards,
    Dwayne
  • Andreas SchererAndreas Scherer Member Andreas SchererOrganization: Private Linux SiteProject: Evaluating Ice-C++, Ice-Python, Ice-Ruby ✭✭
    dwayne wrote: »
    IceJ requires ant 1.6.3 or greater.
    Well, it just depends on your notion of "requirement"; I can happily live with ant 1.6.2, ruby 1.8.2, qt3, etc. in conjunction with Ice 3.x on top of a not-officially-supported (luckily not an officially-not-supported) OS. ;)

    In http://www.zeroc.com/forums/showthread.php?t=2462 I had reported this as a "bug", but since it's easy enough to work around (short of updating to a newer version of ant), I wouldn't want to push this further.

    Thanks and take care,
    Andreas
  • Andreas SchererAndreas Scherer Member Andreas SchererOrganization: Private Linux SiteProject: Evaluating Ice-C++, Ice-Python, Ice-Ruby ✭✭
    BTW, I have noticed tonight that Ice 3.2.0 works fine locally without the cli option
    --Ice.Default.Host=linux
    
    (see http://www.zeroc.com/forums/showpost.php?p=8119&postcount=3). Thanks for saving the extra keystrokes!

    Andreas
Sign In or Register to comment.