Home Help Center

Ice for C# in ubuntu

timberwolftimberwolf Member Bailey WuOrganization: University of SydneyProject: DGC
Hi,

Just wondering if anyone has tried ICE for C# in ubuntu? When I do make install the .dll files in ./bin does not get copied to the installation directory (/opt/IceCS-3.2.0), is this normal? I thought the files in the source directory is supposed to be copied over like ICE for C++.

Comments

  • matthewmatthew NL, CanadaMember Matthew NewhookOrganization: ZeroC, Inc.Project: Internet Communications Engine ✭✭✭
    The dll's are installed into the GAC not into /opt. if you do gacutil -l you can get a list of all installed DLLs.
  • timberwolftimberwolf Member Bailey WuOrganization: University of SydneyProject: DGC
    oh ic, but when it says I need to set the MONO_PATH variable I set it to /opt/IceCS-3.2.0/bin but that doesn't work, I have to set it to the directory where the .dlls are (which is where I compiled the source).

    maybe this is just ubuntu specific...I think the version of mono might be one version behind.
  • matthewmatthew NL, CanadaMember Matthew NewhookOrganization: ZeroC, Inc.Project: Internet Communications Engine ✭✭✭
    If the DLLs are in the GAC you don't need to set MONO_PATH at all to find the Ice DLLs. Perhaps the installation to the GAC failed?
  • timberwolftimberwolf Member Bailey WuOrganization: University of SydneyProject: DGC
    matthew wrote: »
    If the DLLs are in the GAC you don't need to set MONO_PATH at all to find the Ice DLLs. Perhaps the installation to the GAC failed?

    hmm...

    how can I tell if it failed? the installation didn't produce any errors.
  • matthewmatthew NL, CanadaMember Matthew NewhookOrganization: ZeroC, Inc.Project: Internet Communications Engine ✭✭✭
    As I previously said you can do a gacutil -l to list the DLLs that are installed in the GAC. You can also try running the installation commands manually (make -n install in src/Ice to see what the installation would do). Can you also please fix your profile information? You are required to have your full name in the profile to get free support on these forums.
  • timberwolftimberwolf Member Bailey WuOrganization: University of SydneyProject: DGC
    I think it's because I'm not using the ubuntu package, so even though the dlls are getting installed with gacutil -i, mono (installed from a bin file) is not looking in the right places?

    anyway, I think I can live with setting MONO_PATH for now. Thanks
Sign In or Register to comment.