Home Help Center

dns exception

timberwolftimberwolf Member Bailey WuOrganization: University of SydneyProject: DGC
hi,

I have this strange problem with ice throwing dns exception.

I have an icestorm server at 192.168.0.176.

on the subscriber side I have:
IceStorm.TopicManager.Proxy = IceStorm/TopicManager:default -p 10000 -h 192.168.0.176

when the subscriber tries to connection I get dns exception, error =0 host = "0.0.0.0"

if I run the publisher with the same config it's fine. Some how the subscriber just doesn't like 192.168.0.176

ideas anyone?

Comments

  • dwaynedwayne St. John's, NewfoundlandMember Dwayne BooneOrganization: ZeroC, Inc.Project: Internet Communications Engine
    I suspect your problem has nothing to do with the TopicManager proxy but instead with your subscriber's object adapter. What is the configuration you are using for that adapter. I expect that is does not have a host explicitly specified, meaning Ice will try to listen on all local hosts, and it appears that this lookup is failing. I do not know why this would be failing. What operating system is your subscriber running on? Either way, specifing a host in the subscriber's adapter configuration will most likely solve your problem.
  • timberwolftimberwolf Member Bailey WuOrganization: University of SydneyProject: DGC
    dwayne wrote: »
    I suspect your problem has nothing to do with the TopicManager proxy but instead with your subscriber's object adapter. What is the configuration you are using for that adapter. I expect that is does not have a host explicitly specified, meaning Ice will try to listen on all local hosts, and it appears that this lookup is failing. I do not know why this would be failing. What operating system is your subscriber running on? Either way, specifing a host in the subscriber's adapter configuration will most likely solve your problem.

    yeah it is something wrong with the adapter, the code stops at the createObjectAdapter call.

    my subscriber config file is as follows:

    subscriber.radio.Endpoints=tcp:udp
    IceStorm.TopicManager.Proxy =IceStorm/TopicManager:default -p 10000 -h 192.168.0.176

    and I'm running this on Ubuntu 7.04.

    So you mean like if I had: subscriber.radio.Endpoints=tcp:udp -h localhost it would be ok?
  • benoitbenoit Rennes, FranceAdministrators, ZeroC Staff Benoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Hi,

    Which Ice version do you use?

    You should try to enable network tracing on your subscriber to check on which network interfaces the object adapter is trying to bind when you don't specify the -h option in the "subscriber.radio.Endpoints" property.

    Most likely, the solution to your problem will be to add a "-h" in each endpoint of the "subscriber.radio.Endpoints" property. You should specify the IP address of the network interface from which your server will be reached by IceStorm.

    For example:

    subscriber.radio.Endpoints=tcp -h 192.168.0.180:udp -h 192.168.0.180

    if "192.168.0.180" is the IP address of the network interface on your Ubuntu machine.

    Cheers,
    Benoit.
Sign In or Register to comment.