Home Help Center

Multi IP address slow client connections.

Ian JamesIan James Member Ian JamesOrganization: Deutsche BankProject: Equities IT
Hi, Im running an Ice grid with primary and secondary grid nodes. However, when remote clients are firing requests to any service the time it takes to connection to service is either immediate or 20 seconds (approx). With logging i see that there are multiple IP addresses and only one of them works (10.143.29.120, which is the IP i know the box as). Which gets used first seems to be random. How can i get Ice to ignore the dodgy IP and only use 10.143.29.120?

Nov 21, 2007 12:58:57 PM icegrid.ReferenceClient main
INFO: begin
Nov 21, 2007 12:58:57 PM icegrid.ReferenceClient run
INFO: Getting object ref ReferenceService
Nov 21, 2007 12:58:57 PM icegrid.ReferenceClient requestReply
INFO: request reply
[ 11/21/07 12:58:57:873 Location: searching for object by id
object = ReferenceService ]
[ 11/21/07 12:58:57:873 Network: trying to establish tcp connection to 10.143.29.120:10001 ]
[ 11/21/07 12:58:57:920 Network: tcp connection established
local address = 10.129.17.181:2718
remote address = 10.143.29.120:10001 ]
[ 11/21/07 12:58:57:936 Protocol: received validate connection
message type = 3 (validate connection)
compression status = 0 (not compressed; do not compress response, if any)
message size = 14 ]
[ 11/21/07 12:58:57:952 Protocol: sending request
message type = 0 (request)
compression status = 0 (not compressed; do not compress response, if any)
message size = 76
request id = 1
identity = IceGrid/Locator
facet =
operation = findObjectById
mode = 1 (nonmutating)
context = ]
[ 11/21/07 12:58:57:952 Protocol: received reply
message type = 2 (reply)
compression status = 0 (not compressed; do not compress response, if any)
message size = 109
request id = 1
reply status = 0 (ok) ]
[ 11/21/07 12:58:57:952 Location: retrieved endpoints from locator, adding to locator table
object = ReferenceService
endpoints = tcp -h 172.30.70.102 -p 35666:tcp -h 10.143.29.120 -p 35667 ]
[ 11/21/07 12:58:57:952 Network: trying to establish tcp connection to 172.30.70.102:35666 ]
[ 11/21/07 12:59:19:030 Retry: connection to endpoint failed, trying next endpoint
Ice.ConnectFailedException
error = 0 ]
[ 11/21/07 12:59:19:030 Network: trying to establish tcp connection to 10.143.29.120:35667 ]
[ 11/21/07 12:59:19:030 Network: tcp connection established
local address = 10.129.17.181:2728
remote address = 10.143.29.120:35667 ]
[ 11/21/07 12:59:19:030 Protocol: received validate connection
message type = 3 (validate connection)
compression status = 0 (not compressed; do not compress response, if any)
message size = 14 ]
[ 11/21/07 12:59:19:030 Protocol: sending request

Hope someone can help on this!
Thanks
Ian

Comments

  • benoitbenoit Rennes, FranceAdministrators, ZeroC Staff Benoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Hi,

    You need to specify the "-h 10.143.29.120" endpoint option in the configuration of the object adapter which is hosting the "ReferenceService" object. For example:
      <adapter name="MyAdapter" endpoints="tcp -h 10.143.29.120" ... >
          ...
    

    See here in the Ice manual for more information on endpoint options.

    Cheers,
    Benoit.
Sign In or Register to comment.