Home Help Center

Build question on Ice 3.3.0

pdhpdh Member Dan HestandOrganization: University of Massachusetts - LowellProject: PhD dissertation on robotics software architecture
I'm building Ice 3.3.0 on Fedora 8 (not supported, I know) and am getting an error that I don't really know what to do with. The error is

al /link:policy.3.3.Ice /out:policy.3.3.Ice.dll /keyfile:../../../config/IceDevKey.snk
make[3]: al: Command not found

I think I should know what 'al' is but am drawing a blank. Any advice?

Comments

  • pdhpdh Member Dan HestandOrganization: University of Massachusetts - LowellProject: PhD dissertation on robotics software architecture
    Doh! I just noticed that this is in the cs directory so al is the assembly linker for .NET. sorry for the unnecessary post.
  • mefostermefoster Member Mary Ellen FosterOrganization: Heriot-Watt University, EdinburghProject: ECHOES learning environment ✭✭✭
    pdh wrote: »
    I'm building Ice 3.3.0 on Fedora 8 (not supported, I know)

    You shouldn't need to build Ice on Fedora 8; it's actually packaged. It's currently in the updates-testing repository, but it should make it to the main "updates" repository any time now (I've requested that it be moved).

    For now, if you do "yum --enablerepo=updates-testing update ice\*" (or "install" instead of "update" if you don't have it installed yet) you should get the packages. Instead of "ice\*", you can list the specific packages you need; ice-java-devel for Java for writing modules in Java, for example, and ice-devel for servers in C++.

    Let me know (here, or through bugzilla.redhat.com) if you have any issues.

    MEF (Fedora package maintainer)
  • pdhpdh Member Dan HestandOrganization: University of Massachusetts - LowellProject: PhD dissertation on robotics software architecture
    Mary Ellen,
    Thanks for the information. I just tried the yum install and it fails on a missing dependency (ice-libs depends on ice=3.3.0-1.rhel5).

    I'd also be interested in corresponding with you in your work on JAST. I'm using ICE for my PhD dissertation in robotics and would be interested in hearing your experiences. Thanks!

    Dan Hestand
  • mefostermefoster Member Mary Ellen FosterOrganization: Heriot-Watt University, EdinburghProject: ECHOES learning environment ✭✭✭
    pdh wrote: »
    I just tried the yum install and it fails on a missing dependency (ice-libs depends on ice=3.3.0-1.rhel5).

    I'm not sure where either ice-libs or the ".rhel5" part of that error is coming from. On a vanilla Fedora install, neither of those things should come up. What other repositories do you have configured? Do you have Ice RPMs from other sources already installed?
    pdh wrote: »
    I'd also be interested in corresponding with you in your work on JAST. I'm using ICE for my PhD dissertation in robotics and would be interested in hearing your experiences.

    That discussion is probably best done by email rather than on these forums. :) I'll send you a note shortly at the email address mentioned on your web page.

    MEF
Sign In or Register to comment.