Home Bug Reports

HelloWorld syntax error with OpenSuSe11

javiromanjaviroman Madrid (Spain)Member Javier RomanOrganization: www.keedio.comProject: Open Source in Enterprise
Hi:

I've tried to compile the helloworld example in OpenSuse 11.0 386 32bits with gcc 4.3.1 but I get some errors :

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
g++ -I. -c Printer.cpp
In file included from ./Printer.h:23,
from Printer.cpp:13:
/usr/include/Ice/Outgoing.h:56: error: invalid use of ‘::’
/usr/include/Ice/Outgoing.h:56: error: expected ‘;’ before ‘<’ token
/usr/include/Ice/Outgoing.h:84: error: invalid use of ‘::’
/usr/include/Ice/Outgoing.h:84: error: expected ‘;’ before ‘<’ token
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

I have copied the example from documentation.

I've installed the Sle10 version from zeroc.

I know that OpenSuse is not a supported version but i wonder if there is some fixes in order to get running Ice


Thanks.

Comments

  • matthewmatthew NL, CanadaMember Matthew NewhookOrganization: ZeroC, Inc.Project: Internet Communications Engine ✭✭✭
    What is at those lines in the source files? It might be better to try compiling Ice from source, rather than using our RPMs on this unsupported operating system.
  • javiromanjaviroman Madrid (Spain)Member Javier RomanOrganization: www.keedio.comProject: Open Source in Enterprise
    Hi,

    I've managed to compile Ice-3.2.1 and HelloWorld example, nevertheless I've to change the compiler version, from gcc 4.3.1 to gcc 4.1 (also included in OpenSuse 11.0 packages). Anyway I couldn't compile neither with 4.3.1 compiler.

    Thank you.

    Best regards.
  • dwaynedwayne St. John's, NewfoundlandMember Dwayne BooneOrganization: ZeroC, Inc.Project: Internet Communications Engine
    You might have better luck with GCC 4.3 if you used Ice 3.3. I know that it was tested on some platforms with GCC 4.3, while I am pretty sure Ice 3.2.1 never was.
Sign In or Register to comment.