Home Help Center

Necessary RPMs for Ice 3.3

dhogandhogan Member Dirk HoganOrganization: Hewlett-PackardProject: client-server app ✭✭
I recently migrated a Ice 3.2.1 application to Ice 3.3. The application runs on RedHat ES 4.6, so I downloaded the following file:
Ice-3.3.0-rhel4-x86_64-rpm.tar.gz

I would have appreciated the guidance of a README or INSTALL document in this distribution, as stated on the download page, but found none. The application runs on a network not connected to the public internet, so yum did not seem to be an option. So I was left to install rpms in an ad-hoc fasion to support a java IceGrid application. I basically did what seemed to make sense, and installed addtional rpms when the installation of an rpm complained. I'm hoping someone can confirm the correctness of the RPM set I installed - again, it is for a java grid application:

ice-3.3.0-1.rhel4.noarch.rpm
db46-4.6.21-2ice.rhel4.i386.rpm
db46-java-4.6.21-2ice.rhel4.i386.rpm
ice-java-3.3.0-1.rhel4.noarch.rpm
ice-libs-3.3.0-1.rhel4.i386.rpm
ice-utils-3.3.0-1.rhel4.i386.rpm
ice-servers-3.3.0-1.rhel4.i386.rpm
nptl-devel_2.3.4-2.41_i686.rpm \\get this rpm from software repo
ice-c++-devel-3.3.0-1.rhel4.i386.rpm

If there is a INSTALL or README doc which is supposed to be associated with the distribution mentioned above, I would appreciate it if it could be attached to a response to this post.

Thanks

Dirk

Comments

  • matthewmatthew NL, CanadaMember Matthew NewhookOrganization: ZeroC, Inc.Project: Internet Communications Engine ✭✭✭
    dhogan wrote: »
    I'm hoping someone can confirm the correctness of the RPM set I installed - again, it is for a java grid application:

    ice-3.3.0-1.rhel4.noarch.rpm
    db46-4.6.21-2ice.rhel4.i386.rpm
    db46-java-4.6.21-2ice.rhel4.i386.rpm
    ice-java-3.3.0-1.rhel4.noarch.rpm
    ice-libs-3.3.0-1.rhel4.i386.rpm
    ice-utils-3.3.0-1.rhel4.i386.rpm
    ice-servers-3.3.0-1.rhel4.i386.rpm
    nptl-devel_2.3.4-2.41_i686.rpm \\get this rpm from software repo
    ice-c++-devel-3.3.0-1.rhel4.i386.rpm

    You don't need nptl-devel or c++-devel unless you want to develop C++ applications. Also, if you are developing java applications you might want to install the java-devel RPM (it contains slice2freeze, slice2java and the ant build tasks).
    If there is a INSTALL or README doc which is supposed to be associated with the distribution mentioned above, I would appreciate it if it could be attached to a response to this post.

    Thanks

    Dirk

    The INSTALL and such are part of the ice-3.3.0-1.rhel4.noarch.rpm and can be found in /usr/share/doc/ice-3.3.0.
Sign In or Register to comment.