Home Bug Reports

"icegridnode --daemon" does not detach from controlling terminal?

dstndstn Member Dustin LangOrganization: University of TorontoProject: Astrometry.net
Hi,

I just figured out a workaround for this problem, but I thought I'd post a note anyway for the next person to hit this...

When I run:
icegridnode --daemon [args] > logfile 2> errfile

I find that it does not fully detach from the controlling TTY - the symptom is that when you "exit" your SSH session, ssh hangs.
OpenSSH FAQ

I redirected /dev/null to stdin and that solved this problem:
icegridnode --daemon [args] > logfile 2> errfile < /dev/null

I think "icegridnode" should close() stdin -- it doesn't read from stdin, right?

Cheers,
dustin.

PS, this is with Ice 3.3.0, SSH "OpenSSH_4.3p2, OpenSSL 0.9.8b 04 May 2006", on "CentOS release 5.2 (Final)" (rockscluster.org) platform.

Comments

  • bernardbernard Jupiter, FLAdministrators, ZeroC Staff Bernard NormierOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Hi Dustin,

    Thanks for the tip. We'll try to incorporate this in the next release.

    Bernard
  • benoitbenoit Rennes, FranceAdministrators, ZeroC Staff Benoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Hi Dustin,

    I'm afraid we were unable to reproduce this problem with a similar configuration. The IceGrid node already closes stdin and then redirects it to /dev/null unless you start it with --noclose.

    Any chance this could be caused by another process?

    Cheers,
    Benoit.
Sign In or Register to comment.