Home Help Center

about stl

simpleysimpley Member ✭✭
as we know, ice needs stlport-4-5-3, but in my company, any project be asked to use cgi stl 5.3, so if you compile ice on cgi stl, then there are some link error about stl.
so my question is if you must use cgi stl, how can I use ice too!
Coz I like ice so much~~~ :)

Comments

  • marcmarc FloridaAdministrators, ZeroC Staff Marc LaukienOrganization: ZeroC, Inc.Project: The Internet Communications Engine ZeroC Staff
    Sorry, but I'm afraid I don't even know what cgi stl is.

    Ice works with a lot of STL implementations. STLport is only needed for Visual C++ 6.0, because the STL included by this compiler is too buggy. For GCC 3.x, the HP-UX C++ compiler, the Sun C++ compiler, or Visual C++ 7.0 or higher, you don't need STLport.
  • bernardbernard Jupiter, FLAdministrators, ZeroC Staff Bernard NormierOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Maybe you mean SGI STL:
    http://www.sgi.com/tech/stl/FAQ.html

    STLPort started as a port of SGI STL to new compilers ... so you can consider it the newest version of SGI STL.

    Cheers,
    Bernard
  • simpleysimpley Member ✭✭
    thanks all, yeah, cgi must be SGI, so sorry :)

    yeah, we use vc++6.0, there are a few problems using the STLPort in vc++ 6.0, then the another question is when I compiler programme in vc++ 6.0 with STLPort, the compiler always tells me it need the lib file of STLPort, such as stlport_vc6_stldebug.lib, even the programme do not need any stl, why? And how to escape it! thanks again~
  • marcmarc FloridaAdministrators, ZeroC Staff Marc LaukienOrganization: ZeroC, Inc.Project: The Internet Communications Engine ZeroC Staff
    For VC++ 6.0, you must link your Ice programs with the STLport library, because the Ice header files and the generated code need this library.
Sign In or Register to comment.