Home Help Center

Upgrading 3.5 to 3.6 on RHEL6 (yum issues)

dmusgrove1dmusgrove1 Member David MusgroveOrganization: DVTProject: NA
Zeroc Support,

I am attempting to install Ice 3.6 on rhel 6.7 ...

After installing GPG-Key and repo etc... I was getting the following error:

[[email protected]]# yum install ice-all-runtime ice-all-devel
Loaded plugins: refresh-packagekit, security
Setting up Install Process
https://zeroc.com/download/rpm/el6.7/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: zeroc-ice-el6. Please verify its path and try again

I believe the problem is in the URL directory "el6.7" which you are not supporting?

So I edited "zeroc-ice-el6.repo" changing el6.7 to el6 which you seem to support... and all appeared to be fine regarding previous issue...

However a new error arose:


[[email protected]]# yum install ice-all-runtime ice-all-devel
Loaded plugins: refresh-packagekit, security
Setting up Install Process
Resolving Dependencies
--> Running transaction check
--> Blah Blah Blah...
--> Finished Dependency Resolution
Error: Package: php-ice-devel-3.6.0-1.el6.x86_64 (zeroc-ice-el6)
Requires: ice-slice = 3.6.0-1.el6
Error: Package: libice-c++-devel-3.6.0-1.el6.x86_64 (zeroc-ice-el6)
Requires: ice-slice = 3.6.0-1.el6
Error: Package: ice-all-runtime-3.6.0-1.el6.x86_64 (zeroc-ice-el6)
Requires: ice-utils-java = 3.6.0-1.el6
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

I have no idea where to find ice-utils-java and/or ice-slice if your repo is not providing?
Maybe changing the repo file as disscused is causing problems ?

Any insight would be appreciated, thanks.

Regards,
DM

Comments

Sign In or Register to comment.