Home Help Center

icepatch2 and icessl

joseangeljoseangel Member jose angelOrganization: PersonalProject: massive execution
Hi all,

I am new to zeroc ice and after reading documentation and searching the web I am unable to distribute an application using icepatch2 and icessl.

I have written a little python distributed application, a hello world (to start learning zeroc ice). After checking that the application works I have decided to reconfigure zeroc ice to use ssl (one virtual machine for the registry and where the client is executed, and two nodes for server execution). Registry and nodes are working well using SSL (I am able to connect to the java GUI and see both nodes) but when I try to deploy an application using icepatch2 and error arises:

[[email protected] helloworld]# icegridadmin --Ice.Config=client.cfg -u grid -p xxx -e 'application add app-ssl.xml'
-! 01/12/16 16:31:24.785 warning: Ice.ThreadPool.Client.SizeWarn < Ice.ThreadPool.Client.Size; adjusted SizeWarn to Size (100)
-- 01/12/16 16:31:24.785 ThreadPool: creating Ice.ThreadPool.Client: Size = 100, SizeMax = 150, SizeWarn = 100
-- 01/12/16 16:31:24.810 Security: SSL summary for outgoing connection
cipher = DHE-RSA-AES256-GCM-SHA384
bits = 256
protocol = TLSv1.2
local address = 192.168.100.201:39939
remote address = 192.168.100.200:4062
warning: the patch failed on some nodes:
- patch on node `slave1' failed:
Reference.cpp:1663: Ice::NoEndpointException:
no suitable endpoint available for proxy `SyncGridReplyApp.IcePatch2/server -t -e 1.1'
- patch on node `slave2' failed:
Reference.cpp:1663: Ice::NoEndpointException:
no suitable endpoint available for proxy `SyncGridReplyApp.IcePatch2/server -t -e 1.1'
-! 01/12/16 16:31:24.975 warning: thread pool `Ice.ThreadPool.Client' is running low on threads
Size=100, SizeMax=150, SizeWarn=100
[[email protected] helloworld]#

I have tried changing endpoints from tcp to ssl in xml file but it did not work.

The xml configuration file:

<icegrid>
<application name="SyncGridReplyApp" import-default-templates="true">
<replica-group id="grid-reply">
<load-balancing type="round-robin" />
<object identity="SyncGridReplyObj"/>
</replica-group>
<server-template id="SyncGridReplyInstance">
<parameter name="ncpus" />
<server id="SyncGridReplyServer-${node}" exe="python" activation="on-demand" pwd="${server.distrib}">
<option>HelloWorldServerReply.py</option>
<!-- Directive distrib to enable icepatch2 distribution in nodes -->
<distrib/>
<properties>
<property name="LogLevel" value="DEBUG" />
</properties>
<adapter name="SyncGridReplyAdp" register-process="true" endpoints="ssl" replica-group="grid-reply" />
</server>
</server-template>
<node name="slave1">
<!-- set IcePatch2Server port for use with icepatch2client for testing, and listen on all interfaces -->
<server-instance template="IcePatch2" endpoints="ssl -p 10004" directory="/opt/distrib/helloworld"/>
<server-instance template="SyncGridReplyInstance" ncpus="2"/>
</node>
<node name="slave2">
<server-instance template="SyncGridReplyInstance" ncpus="2"/>
</node>
</application>
</icegrid>

Any ideas?? I think that it could be because icepatch2 does not load icessl pluging but I am stucked here and I do not know how to solve.

Thanks in advance,
Sign In or Register to comment.