Home Help Center

Ice_MemoryLimitException PHP 5.5.9

elfelvinelfelvin Member Elvin PetersonOrganization: PrivateProject: Mumble
Hi, I get an error "Ice_MemoryLimitException" when querying ice with PHP 5.5.9 (Ubuntu 14.04) which means the "MessageSizeMax" limit has been reached. In order to fix this I need to set the value ice.options = "--Ice.MessageSizeMax=65536" in the php.ini apache file. The problem is this does not seem to take effect and I continue to get the error "Ice_MemoryLimitException". If I use these same php.ini settings on an Ubuntu 10.04 install then it works fine. Is anyone aware of an issue of ice settings on php 5.5? Is the format ice.options = "--Ice.MessageSizeMax=65536" correct?
If I query phpinfo(); I can see these options set in Ice but somehow it is not taking effect.

Comments

  • mesmes CaliforniaAdministrators, ZeroC Staff Mark SpruiellOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    Hi,

    Welcome to the forum.

    What Ice version are you using?

    Regards,
    Mark
  • elfelvinelfelvin Member Elvin PetersonOrganization: PrivateProject: Mumble
    Hi Mark,

    Thanks for the quick reply.

    [email protected]:~# aptitude show zeroc-ice35
    Package: zeroc-ice35
    State: installed
    Automatically installed: no
    Version: 3.5.1-5.2

    Regards,
    Jason
  • mesmes CaliforniaAdministrators, ZeroC Staff Mark SpruiellOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    Can you paste examples of your Ice configuration settings (from php.ini) as well as the PHP code you're using to initialize a communicator?

    Thanks,
    Mark
  • elfelvinelfelvin Member Elvin PetersonOrganization: PrivateProject: Mumble
    Hi Mark,

    Below are my php settings for Ice

    [email protected]:/etc/php5/apache2# grep ^ice /etc/php5/apache2/php.ini
    ice.slice = "/etc/mumble/Murmur.ice"
    ice.options = "--Ice.MessageSizeMax=64536"
    [email protected]:/etc/php5/apache2#

    Correct me if I'm wrong but I believe you are looking for the below code? I am using a project called "phpmumbleadmin" which is not developed by me.

    protected function connectionIce35()
    {
    $this->debug(__function__);
    /**
    * Memo for Meta -e 1.0
    * See http://doc.zeroc.com/display/Doc/New+in+Ice+3.5%3A+Encoding+Version+1.1
    */
    try {
    $proxy = $this->ICE->stringToProxy(
    'Meta -e 1.0 :tcp -h '.$this->host.' -p '.$this->port.' -t '.$this->timeout
    );
    } catch (Exception $e) {
    $this->throwException($e);
    }
    if (! interface_exists('Murmur_Meta')) {
    $this->throwException('ice_no_slice_definition_found');
    }
    try {
    $this->meta = Murmur_MetaPrxHelper::checkedCast($proxy)->ice_context($this->secret);
    } catch (Exception $e) {
    $this->throwException($e);
    }
    }

    Thanks,
    Jason





  • mesmes CaliforniaAdministrators, ZeroC Staff Mark SpruiellOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    Hi,

    Unfortunately we don't provide Mumble support here. There are a lot of Mumble users registered here but I'm not sure any of them will respond to your post. I'd encourage you to post this question in a Mumble-specific forum instead.

    Regards,
    Mark
  • bernardbernard Jupiter, FLAdministrators, ZeroC Staff Bernard NormierOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    You could also try the Ice 3.6.1 packages we provide for Ubuntu 14.04 LTS: https://zeroc.com/downloads/ice.

    Ice 3.6 removed outgoing checks from Ice.MessageSizeMax.

    Best regards,
    Bernard
Sign In or Register to comment.