It seems your PHP configuration is not running with the Ice extension?

RelfieRelfie Member MichaelOrganization: PersonalProject: Mumble Viewer

ok...I've been working on this for days and scowering the internet for answers. I am running Ice 3.5.1 and XAMPP 1.8.1. I've followed the http://wiki.mumble.info/wiki/Ice#How_to_setup_Ice_for_PHP_with_Apache_on_Windows to a "T" and can't seem to get this running. I've even Copied the 8 vc90.dll files from the bin dir of Ice to the Xampp\apache folder. Can someone shed some light as to what I'm doing wrong. Just trying to get MumPI working for a viewer on our guild's webpage.

Best Answers

Answers

  • xdmxdm ZeroC Staff La Coruña, SpainAdministrators, ZeroC Staff Jose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    Accepted Answer

    The setup of Ice for PHP on Windows for Ice 3.5.1 is described here

    https://doc.zeroc.com/display/Ice35/Using+the+Windows+Binary+Distribution#UsingtheWindowsBinaryDistribution-PHP

    Try to use that instructions instead.

  • RelfieRelfie Member MichaelOrganization: PersonalProject: Mumble Viewer
    edited June 2016

    I'm obviously doing something completely stupid. I still get the same damn error. Thanks though. I shall spends more days figuring it out I suppose =(

    I am running the correct version of Xampp, correct? It installs PHP 5.4.7

  • RelfieRelfie Member MichaelOrganization: PersonalProject: Mumble Viewer

    I actually have a feeling that my problem resides in here:

    ; UNIX: "/path1:/path2"
    ;include_path = ".:/php/includes"
    ;
    ; Windows: "\path1;\path2"
    include_path = "C:\Program Files (x86)\ZeroC\Ice-3.5.1\php"
    ;
    ; PHP's default setting for include_path is ".;/path/to/php/pear"
    ; http://php.net/include-path

    ; The root of the PHP pages, used only if nonempty.
    ; if PHP was not compiled with FORCE_REDIRECT, you SHOULD set doc_root
    ; if you are running php as a CGI under any web server (other than IIS)
    ; see documentation for security issues. The alternate is to use the
    ; cgi.force_redirect configuration below
    ; http://php.net/doc-root
    doc_root =

    ; The directory under which PHP opens the script using /~username used only
    ; if nonempty.
    ; http://php.net/user-dir
    user_dir =

    ; Directory in which the loadable extensions (modules) reside.
    ; http://php.net/extension-dir
    ; extension_dir = "./"
    ; On windows:
    extension_dir = "C:\xampp\php\ext"

  • xdmxdm ZeroC Staff La Coruña, SpainAdministrators, ZeroC Staff Jose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff

    Hi Michael,

    Did you get things working?

  • RelfieRelfie Member MichaelOrganization: PersonalProject: Mumble Viewer

    no, still getting that same error. Everything looks correct to me though...

  • xdmxdm ZeroC Staff La Coruña, SpainAdministrators, ZeroC Staff Jose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff

    Can you clarify if the extension is being loaded?

    You must check system logs, and apache logs for any errors, without more info is difficult to know what is going wrong.

  • RelfieRelfie Member MichaelOrganization: PersonalProject: Mumble Viewer

    [Wed Jun 29 11:54:40.931680 2016] [mpm_winnt:notice] [pid 2840:tid 504] AH00422: Parent: Received shutdown signal -- Shutting down the server.
    [Wed Jun 29 11:54:42.958440 2016] [mpm_winnt:notice] [pid 2860:tid 400] AH00364: Child: All worker threads have exited.
    [Wed Jun 29 11:54:43.005315 2016] [mpm_winnt:notice] [pid 2840:tid 504] AH00430: Parent: Child process exited successfully.
    [Wed Jun 29 11:54:50.048661 2016] [ssl:warn] [pid 3736:tid 504] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
    [Wed Jun 29 11:54:50.095542 2016] [mpm_winnt:notice] [pid 3736:tid 504] AH00455: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
    [Wed Jun 29 11:54:50.095542 2016] [mpm_winnt:notice] [pid 3736:tid 504] AH00456: Server built: Aug 18 2012 12:41:37
    [Wed Jun 29 11:54:50.095542 2016] [core:notice] [pid 3736:tid 504] AH00094: Command line: 'C:\xampp\apache\bin\httpd.exe -d C:/xampp/apache'
    [Wed Jun 29 11:54:50.111165 2016] [mpm_winnt:notice] [pid 3736:tid 504] AH00418: Parent: Created child process 4004
    [Wed Jun 29 11:54:51.220539 2016] [ssl:warn] [pid 4004:tid 400] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
    [Wed Jun 29 11:54:51.282981 2016] [mpm_winnt:notice] [pid 4004:tid 400] AH00354: Child: Starting 150 worker threads.

    This is my Apache Error logs...it's not loading the Ice Extension that I can see...

  • RelfieRelfie Member MichaelOrganization: PersonalProject: Mumble Viewer


    • 26
      0
      4
      0
      0
      0x8000000000000000

      1404


      System
      Windows2012Server


    • Warning
      PHP Startup: Unable to load dynamic library 'C:\xampp\php\ext\php_ice.dll' - The specified module could not be found.

    found this in windows log file....

  • xdmxdm ZeroC Staff La Coruña, SpainAdministrators, ZeroC Staff Jose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    PHP Startup: Unable to load dynamic library 'C:\xampp\php\ext\php_ice.dll' - The specified module could not be found. 
    

    You must check two things:

    • Ensure that apache has access to the 'C:\xampp\php\ext\php_ice.dll'

    • Ensure the require dependencies are in the apache's executable search path. Try to add the Ice bin directory to your system PATH. Use system variables not user variables as Apache doesn't run as your user.

  • RelfieRelfie Member MichaelOrganization: PersonalProject: Mumble Viewer

    yeah, I do have my Ice\bin directory added to my system PATH.

    php_ice.dll is also at C:\xampp\php\ext so it should read read it, correct? I also have all of the Required dependiencies, total of 8, in the \xampp\apache folder.

    I even took the 5.4.27 binaries and used them instead...same issue. It's not a software compatibility issue is it?

  • RelfieRelfie Member MichaelOrganization: PersonalProject: Mumble Viewer

    I've also added the extension=php_ice.dll into my php.ini configuration.

  • xdmxdm ZeroC Staff La Coruña, SpainAdministrators, ZeroC Staff Jose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    Accepted Answer

    Hi,

    The problem is that Apache version included in XAMP was build with VC100 and that cause a conflict when Ice_php.dll tries to load the VC90 C++ run-time.

    You need to use an Apache version build with VC90, like https://www.apachehaus.com/cgi-bin/download.plx#APACHE22VC09

  • RelfieRelfie Member MichaelOrganization: PersonalProject: Mumble Viewer

    ok...I've been trying all kinds of stuff...lol.

    I'm currently running xampp 1.7.5 with Ice 3.4.2 and I now have it up and running. Thanks for your help Xdm!

Sign In or Register to comment.