Replication group without Icegrid deployment

nathanbnlnathanbnl Member Nathan DeveloperOrganization: IPerityProject: telephony services

We're trying to use ICE fail-over using replication groups and IceGrid locator services, but without the Icegrid deployment services.

Our server creates an object adapter with properties "ReplicaGroupId" and "AdapterId" set.
This seems to succeed, according to icegridadmin:

icegridadmin --Ice.Default.Locator="xxx/Locator:tcp -h xxx -p 4061" -e "adapter endpoints MyReplicationGroup"

xxx.nathancmp01_api: dummy -t -e 1.1:tcp -h myip1 -p 40085
xxx.nathancmp02_api: dummy -t -e 1.1:tcp -h myip2 -p 35572

But if any client tries to use the replication group, we get this error:

LocatorInfo.cpp:742: Ice::NotRegisteredException: no object adapter with id `MyReplicationGroup' is registered

The setup was working fine when we were using Icegrid deployment to create an application and icebox for service deployment.

(tested using Ubuntu with zeroc-ice35)

Answers

  • benoitbenoit Rennes, FranceAdministrators, ZeroC Staff Benoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff

    Hi,

    Can you upgrade to the latest Ice 3.6.3 and see if it fixes the problem? There's a well known bug in Ice < 3.6.2 which could be the reason for this exception.

    Cheers,
    Benoit.

  • nathanbnlnathanbnl Member Nathan DeveloperOrganization: IPerityProject: telephony services

    Thanks, using Icegridnode version 3.6.3 this seems to work fine.

    I'm having trouble finding the PHP packages though, can't find them in https://zeroc.com/download/apt/ubuntu16.04/pool/main/z/zeroc-ice3.6/ ?

  • benoitbenoit Rennes, FranceAdministrators, ZeroC Staff Benoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff

    Hi,

    Yes, Ubuntu 16.04 only provides php 7.0 packages and Ice 3.6.3 doesn't support php 7.0. It will be supported with the next Ice 3.7 release. PHP packages are available with Ubuntu 14.04 however.

    Cheers,
    Benoit.

Sign In or Register to comment.