Cannot use ice demos on ubuntu 16.04 - Urgent help

lovemehtalovemehta Member Love MehtaOrganization: RobocompProject: Robocomp uses ice as its communication middleware

This is what I did -
1. Installed fresh Ubuntu 16.04 on VirtualBox
2. Installed Zeroc Ice 3.6 from https://zeroc.com/distributions/ice using the following commands :
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv 5E6DA83306132997
sudo apt-add-repository "deb http://zeroc.com/download/apt/ubuntu$(lsb_release -rs) stable main"
sudo apt-get update
sudo apt-get install zeroc-ice-all-runtime zeroc-ice-all-dev
3. Also installed nodejs and npm.
sudo apt-get install nodejs
sudo apt install npm
sudo apt-get install nodejs-legacy
4. Installed JavaScript Distribution of Ice using npm -
npm install ice
npm install slice2js
npm install gulp-ice-builder
Now i clone the repo -

  1. git clone https://github.com/zeroc-ice/ice-demos.git

  2. cd ice-demos/js

  3. npm install

I get the following errors -

Please help because I have tried a lot of times and it just doesnt work.
Also after installing when i just write slice2js on the terminal and press enter - it shows this error -

No command 'slice2js' found, did you mean:
Command 'slice2cs' from package 'ice35-translators' (universe)
slice2js: command not found

Best Answers

  • xdmxdm La Coruña, SpainJose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    Accepted Answer

    You should switch to 3.6 branch of the demos 3.7 has not been yet published, if you really want to test 3.7 you will need to build it from sources see Build instructions in ice-demos/js and ice/js

  • xdmxdm La Coruña, SpainJose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    Accepted Answer

    Yes this changed from 3.6 to 3.7 you are still looking at 3.7 instructions, check instructions in 3.6 branch

  • xdmxdm La Coruña, SpainJose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    Accepted Answer

    you need to use ctrl+C

Answers

  • xdmxdm La Coruña, SpainAdministrators, ZeroC Staff Jose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    Accepted Answer

    You should switch to 3.6 branch of the demos 3.7 has not been yet published, if you really want to test 3.7 you will need to build it from sources see Build instructions in ice-demos/js and ice/js

  • lovemehtalovemehta Member Love MehtaOrganization: RobocompProject: Robocomp uses ice as its communication middleware

    Hello,

    I cloned the 3.6 branch now when i run npm install it works fine with a few warnings but now when i run npm run build command in the js folder it says this
    i checked to there was no build file in the directory. it says in the instructions that - Now use gulp to build the demos. so how to do that. Simply writing the npm run build wont work.

  • xdmxdm La Coruña, SpainAdministrators, ZeroC Staff Jose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    Accepted Answer

    Yes this changed from 3.6 to 3.7 you are still looking at 3.7 instructions, check instructions in 3.6 branch

  • lovemehtalovemehta Member Love MehtaOrganization: RobocompProject: Robocomp uses ice as its communication middleware
    edited July 2017

    hello,
    ok so the demos are working fine but there is one minor doubt i have. How to stop a server running on a terminal such that it does not leave this error when rerun in the same terminal -

    !! 07/19/17 17:22:05.877 ./server: error: Network.cpp:2065: Ice::SocketException:
    socket exception: Address already in use

    I used ctrl+Z last time i shut the server and i think this does not releases the port properly. Also, Killing the terminal works.

  • xdmxdm La Coruña, SpainAdministrators, ZeroC Staff Jose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    Accepted Answer

    you need to use ctrl+C

Sign In or Register to comment.