Installation of Ice 3.6 on Ubuntu 16.04.3 32 bit

kdobbkdobb Klaus DobblerOrganization: personProject: the project is for the synchronization of files in network with multiple peersMember

Hi,

I'm facing a problem with installation of ICE 3.6 on a Ubuntu 16.04.3 32 bit VM.

After adding

sudo apt-add-repository "deb http://zeroc.com/download/Ice/3.6/ubuntu16.04 stable main"
sudo apt-get update

I exec

sudo apt-get install zeroc-ice-all-runtime zeroc-ice-all-dev

and get an error message, that packages cannot be installed.

e.g. zeroc-ice-all-runtime is dependent on libzeroc-ice3.6 (= 3.6.3-1000), but is not installable.

Any Idea why this problem occurs?

Thanks,

BR Klaus

Comments

  • xdmxdm La Coruña, SpainJose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice DeveloperAdministrators, ZeroC Staff ZeroC Staff
    edited September 2017

    Hi Klaus,

    Seems you have Ubuntu Ice packages that are not compatible with our packages, probably Ice 3.5 from Ubuntu repositories.

    Can you paste the complete error message and the output of

    dpkg-query -l | grep ice
    

    Note that we only provide amd64 packages for Ubuntu 16.04, there are not i686 (32bit) packages

  • kdobbkdobb Klaus DobblerOrganization: personProject: the project is for the synchronization of files in network with multiple peersMember

    Hi Jose,

    thanks for you message.

    Ok, I've seen under supported platforms, that 32 bit packages are only available for Ubuntu 14, so I'm currently setting up a new VM.

    The point is, I would like to use ICE-PHP, and this requires 32bit XAMPP-stack as far as i experienced, which is only available for 32 bit linux systems. Am I right, that PHP is only supported for 32 bit webservers?

    Thanks,

    BR Klaus

  • kdobbkdobb Klaus DobblerOrganization: personProject: the project is for the synchronization of files in network with multiple peersMember

    output of dpkg-query command is in the attachment

    so2.txt 13.5K
  • kdobbkdobb Klaus DobblerOrganization: personProject: the project is for the synchronization of files in network with multiple peersMember

    Installation works under ubuntu 14.04

  • xdmxdm La Coruña, SpainJose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice DeveloperAdministrators, ZeroC Staff ZeroC Staff

    Yes we drop i386 packages with 16.04 , we still provide them for 14.04

  • tzisolutionstzisolutions prakhar getheOrganization: TZi Solutions Private LimitedProject: Android project to connect App with Server to execute certain commands for NFC Member

    But when i install despite the fact that i have amd64 version isntalled it says that it doesn't support i386 version why ?

    I am using latest version of installation instruction as given in manual

  • benoitbenoit Rennes, FranceBenoit FoucherOrganization: ZeroC, Inc.Project: IceAdministrators, ZeroC Staff ZeroC Staff

    Hi,

    According to the dpkg-query output, you have i386 packages installed which would indicate that you are not using a 64bits Ubuntu 16.04 installation.

    Can you provide us with the output of the following command to check the architecture of your Ubuntu 16.04 distribution: dpkg --print-architecture.

    Cheers,
    Benoit.

Sign In or Register to comment.