question about icegrid load balance for ice 3.2.1

mill888mill888 Member Can LinOrganization: PersonalProject: Just for study
edited April 2018 in Help Center

I had post a message on https://forums.zeroc.com/discussion/46613/question-about-icegrid-load-balance#latest
Although version >=3.5 has the function, But I had to use Ice 3.2.1, because I had to use AIX 5.3, and IBM XLC 8.0,and ice version >=3.2.1 can not be compiled on AIX 5.3, and IBM XLC 8.0.

So Anyone can patch it for me ?

Thanks ahead !

Tagged:

Best Answer

  • benoitbenoit ZeroC Staff Rennes, FranceBenoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Accepted Answer

    Hi,

    The only other option I can think of would be to install a recent version of GCC and try to compile Ice 3.7 with it. This might require also building 3rd party dependencies (mcpp, lmdb, expat, openssl) or find binaries for them in a repository. You could checkout the AIX Toolbox for Linux from IBM to get GCC and other binaries needed to build Ice.

    Cheers,
    Benoit.

Answers

  • mill888mill888 Member Can LinOrganization: PersonalProject: Just for study
    edited April 2018

    correct a mistake: ice version > 3.2.1 (not version >= 3.2.1) can not be compiled on AIX 5.3, and IBM XLC 8.0.

    I think it must be easy for you, just firstly check the server whether is enabled before Locate it.

    But I do now know where to alter the souce code.

    So Anyone can patch it for me ?

  • benoitbenoit ZeroC Staff Rennes, FranceAdministrators, ZeroC Staff Benoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff

    Hi,

    Ice 3.6 should build on AIX 6.1 with xlC 12.1 (see BuildInstructionsAIX.md). Could you perhaps upgrade your AIX system to this version to use a recent Ice version?

    I'm afraid patching Ice 3.2.1 to support this feature is a bit of work and it's out the scope of the free support we can provide on the forums.

    Cheers,
    Benoit.

  • mill888mill888 Member Can LinOrganization: PersonalProject: Just for study

    yeah, thank you for your answer;
    But I had to use AIX 5.3 withc xlC 8, Because I am just a student, and in my laboratory, there is only AIX 5.3 with xlC 8.

    So, .....

  • benoitbenoit ZeroC Staff Rennes, FranceAdministrators, ZeroC Staff Benoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Accepted Answer

    Hi,

    The only other option I can think of would be to install a recent version of GCC and try to compile Ice 3.7 with it. This might require also building 3rd party dependencies (mcpp, lmdb, expat, openssl) or find binaries for them in a repository. You could checkout the AIX Toolbox for Linux from IBM to get GCC and other binaries needed to build Ice.

    Cheers,
    Benoit.

Sign In or Register to comment.