undefined symbol: SSLeay

StefanOnIce42StefanOnIce42 Member Stefan ConstantinOrganization: PersonalProject: Dialogsystem

Hello,

I get by importing Ice in Python the following error:
IcePy.cpython-36m-x86_64-linux-gnu.so: undefined symbol: SSLeay

I use Ubuntu 14.04 and Python 3.6. With Python 3.5 it is working, but I need Python 3.6 for a library.

Answers

  • xdmxdm La Coruña, SpainAdministrators, ZeroC Staff Jose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff

    Hi Stefan,

    Can you tell us how did you install Ice for Python extension?

  • StefanOnIce42StefanOnIce42 Member Stefan ConstantinOrganization: PersonalProject: Dialogsystem

    I installed it with pip install --upgrade zeroc-ice=3.7.2.

  • StefanOnIce42StefanOnIce42 Member Stefan ConstantinOrganization: PersonalProject: Dialogsystem

    I tried it also with pip install --upgrade zeroc-ice=3.7.1, but then I get the following error:
    undefined symbol: X509_chain_up_ref

  • xdmxdm La Coruña, SpainAdministrators, ZeroC Staff Jose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff

    I don't see Python 3.6. supported with Ubuntu 14.04, how you get that?

  • StefanOnIce42StefanOnIce42 Member Stefan ConstantinOrganization: PersonalProject: Dialogsystem

    I got it via a PPA (ppa:fkrull/deadsnakes).

  • xdmxdm La Coruña, SpainAdministrators, ZeroC Staff Jose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff

    I don't see a pip 3.6 package there, how did you get pip? After installing python3.6 from the ppa, pip is stily using python2.7

    [email protected]:~$ pip -V
    pip 1.5.4 from /usr/lib/python2.7/dist-packages (python 2.7)
    [email protected]:~$ pip3 -V
    pip 1.5.4 from /usr/lib/python3/dist-packages (python 3.4)
    
  • StefanOnIce42StefanOnIce42 Member Stefan ConstantinOrganization: PersonalProject: Dialogsystem
    edited February 26

    Sorry, I have a virtualenv, therefore pip3 is linked to pip (I used pip3). It seems that zeroc-ice=3.7.0 is working. I am testing it.

  • StefanOnIce42StefanOnIce42 Member Stefan ConstantinOrganization: PersonalProject: Dialogsystem

    It is working with zeroc-ice=3.7.0. I guess the libraries of Ubuntu 14.04 are too old for newer versions of Ice.

  • xdmxdm La Coruña, SpainAdministrators, ZeroC Staff Jose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff

    Same IceSSL library version should work for 3.7.0 and 3.7.1 and 3.7.2, we do not change dependency requirements in patch releases. Can you build with verbose output and upload the build log?

Sign In or Register to comment.