Home Help Center

Centos 7: /usr/lib64/php/modules/ice.so: undefined symbol: zval_used_for_init

FenryllFenryll Member cyril wannazOrganization: chibre.chProject: chibre.ch

Hi,

Long story short: I just installed Mumble on a dedicated server (Centos 7.9 / PHP 7.2.34), now I am trying to install a PHP web interface (MumPI that is requiring PHP-ice.

I followed the installation guide I found here for RHEL 7, all libraries are now installed, but now when if do a 'php -m' or 'php -i | grep include_path' I have the following warning:
PHP Warning: PHP Startup: Unable to load dynamic library 'ice.so' (tried: /usr/lib64/php/modules/ice.so (/usr/lib64/php/modules/ice.so: undefined symbol: zval_used_for_init), /usr/lib64/php/modules/ice.so.so (/usr/lib64/php/modules/ice.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0

I tried many things, but I am stuck now: any help would be greatly appreciated!

Thanks!

Answers

  • FenryllFenryll Member cyril wannazOrganization: chibre.chProject: chibre.ch

    Is it a compatibility issue with PHP 7 ?

  • xdmxdm La Coruña, SpainAdministrators, ZeroC Staff Jose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff

    Hi Cyril,

    Centos 7 packages are built with php5 if you need to use php7 you have to build Ice PHP from sources, see https://github.com/zeroc-ice/ice/tree/3.7/php

  • FenryllFenryll Member cyril wannazOrganization: chibre.chProject: chibre.ch

    Thank you so much to give me a path forward !

  • FenryllFenryll Member cyril wannazOrganization: chibre.chProject: chibre.ch

    Hi,

    following the documentation I managed to build the library for PHP, all allTests.py are ok, I followed then the configuration for RHEL 7 /PHP doc..
    I can see "ice" listed when I run "php -m", BUT ice is not listed on phpinfo().. and the mumble Web interface is still reporting that my "PHP configuration is not running with the Ice extension".

    I already tried a lot of things with no luck.. any help / clue would really be appreciated :)

  • xdmxdm La Coruña, SpainAdministrators, ZeroC Staff Jose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff

    You need to copy the extension to php extension dir, and don't forget to uninstall the previous version?

    There is more detailed instructions in the source repository https://github.com/zeroc-ice/ice/tree/3.7/php#linux-or-macos-1

Sign In or Register to comment.