Crash in demo IceStorm replicated2

YosYos Member Jose FernandezOrganization: University of Malaga (Spain)Project: Comparision between Ice VS Corba
when i run the subscriber.exe sometimes happen this:

C:\Ice-3.3.0-VC60\demo\IceStorm\replicated2>subscriber.exe
Assertion failed: !_acceptor, file ConnectionFactory.cpp, line 1507
Assertion failed: InterlockedExchangeAdd(&_ref, 0) > 0, file Shared.cpp, line 13
2
Assertion failed: InterlockedExchangeAdd(&_ref, 0) > 0, file Shared.cpp, line 13
2
.
.
.
.

If i dont press Ctrl+C continues the same thing.

But surprise¡¡¡ after Ctrl+C i retry to run the program and all run ok

Have you any ideas??

Comments

  • matthewmatthew NL, CanadaMember Matthew NewhookOrganization: ZeroC, Inc.Project: Internet Communications Engine ✭✭✭
    I guess this is when you have a publisher running? It looks like it is getting some failure when receiving events from IceStorm. Since you are running with debugging, an assertion failure dialog should be popped prompting you to attach a debugger, or kill the application. Until you confirm, the application continues to run.

    On this forum we only offer free support for the latest version of Ice. Can you try this with Ice 3.3.1 before we look into this further?
  • YosYos Member Jose FernandezOrganization: University of Malaga (Spain)Project: Comparision between Ice VS Corba
    Now all run ok

    Hi,

    I have been trying the same demo with Ice-3.3.1 several times and I haven`t found any error.

    So i'm suppose to something was changed from Ice-3.3.0 to Ice-3.3.1 about IceStorm to better......:D



    Thanks
Sign In or Register to comment.