Home Help Center

Problems installing icegridnode service

jharriotjharriot Member John HarriottOrganization: BAE SystemsProject: P3 Mid Life Upgrade ✭✭
Here is my configuration:
Windows XP running as a VM (VMWare Server 1.0.4)
Ice 3.3.1
My application was installed using a custom installer. Installer payload includes the application, ice config files and all Ice binaries.
The installation was performed as Admin and the app was installed into C:\Program Files\CompanyName\App folder.
N.B. I have not run the Ice MSI installer to install Ice.

The problem
When I run the icserviceinstall (from a batch file within the installation folder) utility I get the following message:
..\bin\iceserviceinstall --DependOnRegistry=1 --Autostart=1 icegridnode "c:\Documents and Settings\LocalService\Application Data\SwSIM\IceGridNode.cfg"
Error: Could not retrieve effective rights for NT Authority\LocalService on MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib: The trust relationship between this workstation and the promary domain failed.


I tried adding LocalService read permissions to the Perlib using regedit..but no still no improvement.

If I run the utility with the IceGridNode config file located in the installation folder I get a similar trust error:
Error: Could not retrieve effective rights for NT Authority\LocalService on c:\Program Files\blah...blah\config\db\node.

I could understand the error above as the installation folder doesn't have LocalService access permissions.

N.B. I have been able to install the icegrigrestriy service as long as I use the config file located under "c:\Documents and Settings\LocalService\Application Data\SwSIM"

Regards John

Comments

  • benoitbenoit Rennes, FranceAdministrators, ZeroC Staff Benoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Hi John,

    The IceGrid node needs to be granted special permissions for accessing performance data of the machine, this is done by the setting of the PerfLib registry key (see this Microsoft link for more information).

    For some reasons, iceserviceinstaller fails to set these permissions on your machine. From the error message you're getting, it looks like this could be because of the following: Trust Relationship Between Workstation and Domain Fails

    Could you try out the suggestions from this page and see if it fixes your problem?

    Cheers,
    Benoit.
Sign In or Register to comment.