Home Help Center

make test error! demo error!

zeronumberzeronumber Member jack zhangOrganization: DawningProject: Beijing police station
hi, guys!

I had some troubles to install ice-2.1.0 on my server.
The OS is Redhat AS 5U2 x86_64.
I had installed GCC 3.4.6,openssl-0.9.7e,bzip2-1.0.2,db-4.2.52
and the other third-party libraries are expat-1.95.8-8.2.1,ncurses-5.5-24.20060715,readline-5.1-1.1

I had compiled and installed Ice-2.1.0 successfully .
when i run "make test" i got some errors.

One error is "test mutex failed", and i had corrected by this way. see this thread.

Another one is "./test/Freeze/evictor/client: double free or corruption (fasttop): 0x0000000015572cb0 ***",but it does not appears when i run "make test" today.

Now "make test" is ok,but when i run the demo program "Ice-2.1.0/demo/book/printer/server" , the return
Network.cpp:413: Ice::SocketException:
socket exception: Cannot assign requested address

I try to test orther demo programs, and it can not run successfully also.
such as

cd Ice-2.1.0/demo/IcePack/hello/
./server
./server: ObjectAdapterI.cpp:843: Ice::IllegalIdentityException:
illegal identity: `'


what can i do .

I want to install Ice-2.1.0 on Redhat AS 5u2. can it works?

Thanks!

Comments

  • benoitbenoit Rennes, FranceAdministrators, ZeroC Staff Benoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Hi,

    We don't provide free support on the forums for old Ice versions. Could you upgrade to Ice 3.3.1 and see if you can still reproduce this problem?

    Cheers,
    Benoit.
Sign In or Register to comment.