Home Help Center

Problem while installing zeroc-ice on Ubuntu

eddi96eddi96 Member Eduard KluschOrganization: IntechMediaProject: Mumblehosting with Webinterface based on ICE
Good evening,

I have a problem when i try to install the package "zeroc-ice" via apt-get.
It installs almost all requiered packages from the repository, but it stops here:
Unpacking slice2cpp (from .../slice2cpp_3.2.1-3_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/slice2cpp_3.2.1-3_amd64.deb (--unpack):
trying to overwrite `/usr/bin/slice2cpp', which is also in package ice-c++-devel
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Unpacking slice2freeze (from .../slice2freeze_3.2.1-3_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/slice2freeze_3.2.1-3_amd64.deb (--unpack):
trying to overwrite `/usr/bin/slice2freeze', which is also in package ice-c++-devel
Unpacking libzeroc-ice-dev (from .../libzeroc-ice-dev_3.2.1-3_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libzeroc-ice-dev_3.2.1-3_amd64.deb (--unpack):
trying to overwrite `/usr/include/Freeze/Catalog.h', which is also in package ice-c++-devel
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/slice2cpp_3.2.1-3_amd64.deb
/var/cache/apt/archives/slice2freeze_3.2.1-3_amd64.deb
/var/cache/apt/archives/libzeroc-ice-dev_3.2.1-3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I've tried the command "apt-get -f install", but it gives the same error.
Can you help me to solve this problem?
I can't install any more packages at all, it alway stops with
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
ice-translators: Depends: slice2cpp but it is not going to be installed
Depends: slice2freeze but it is not going to be installed
zeroc-ice: Depends: libzeroc-ice-dev but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I have Ubuntu amd64.

Thank you very much for help.
Best regards
Eddi

Comments

  • xdmxdm La Coruña, SpainAdministrators, ZeroC Staff Jose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    Hi Eduard,

    Seems that there is some problem with Ubuntu packages or with your Ubuntu setup, Ubuntu packages aren't provided by ZeroC, you should ask on Ubuntu forums.

    Note that our free support is limited to the latest released Ice versions, currently is Ice 3.3.1, Ice 3.4 will be released in short, Ice 3.2.1 is quite old now.

    Bests Regards,
    José
Sign In or Register to comment.