Home Help Center

Unable to initialize module [Help]

cooldreng13cooldreng13 Member Oliver LarsenOrganization: PersonalProject: setting up a mumble server
Hi ZecoC folks

ive got this problem when i start my apache server...
PHP Startup: ice: Unable to initialize module
Module compiled with module API=20060613
PHP     compiled with module API=20090626
These options need to match

Im using Windows XP
and EasyPHP 5.3.1

i have installed ICE

what do i need to recompile and how shall i do?


Thanks in advance :)

Comments

  • mesmes CaliforniaAdministrators, ZeroC Staff Mark SpruiellOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    Hi Oliver,

    Welcome to the forum!

    In order to use the PHP extension included in an Ice installer, you must use a compatible version of PHP. For Ice 3.3.1, the PHP extension is compatible with PHP 5.2.6.

    If you require PHP 5.3, you can use the installer for Ice 3.4b. Note however that the PHP extension in this Ice release is not backward compatible and likely will not work with Mumble.

    I think your best option at this point is to use PHP 5.2.x.

    Hope that helps,
    Mark
  • cooldreng13cooldreng13 Member Oliver LarsenOrganization: PersonalProject: setting up a mumble server
    Okay.

    I will get the older version then...

    thanks for the help :)
Sign In or Register to comment.