Patch for building against newer openssl

mefostermefoster Member Mary Ellen FosterOrganization: Heriot-Watt University, EdinburghProject: ECHOES learning environment ✭✭✭
Fedora has openssl-1.0.0 (beta 4). To build against this, the attached patch is required. Note: despite the filename, this patch is also needed (and applies cleanly) against Ice 3.4.0.

Sorry for not posting this here sooner,

MEF

Comments

  • phil++phil++ Member Philip KovacsOrganization: University of PennsylvaniaProject: Ice Storm Evaluation
    It is more elegant and efficient to observe that the Ice code merely inspects the cipher pointer. It is therefore perfectly good practice to const the pointer unconditionally.

    See attachment.

    Cheers,

    Phil
Sign In or Register to comment.