IceTouch iphone simulator apps crash on start

l2succesl2succes Member Luc SuccesOrganization: NYU ACM student chapterProject: Robot iphone client
Hi, I'm having some trouble running compiled IceTouch applications on the iphone simulator. I've been able to successfully compile the examples as well as my own ice project. However when the application attempts to run, i get the following error.

Process: Chat [5115]
Path: /Users/dev/Library/Application Support/iPhone Simulator/User/Applications/5EC34415-EA79-47F1-88BC-3CA7EE192AE8/Chat.app/Chat
Identifier: Chat
Version: ??? (???)
Code Type: X86 (Native)
Parent Process: launchd [102]

Interval Since Last Report: 234 sec
Crashes Since Last Report: 1
Per-App Interval Since Last Report: 0 sec
Per-App Crashes Since Last Report: 1

Date/Time: 2010-03-15 17:52:18.979 -0400
OS Version: Mac OS X 10.5.7 (9J61)
Report Version: 6
Anonymous UUID: 0B9C4184-D112-42B7-B465-CE221AEFAF99

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread: 0

Dyld Error Message:
Symbol not found: _kCFXMLTreeErrorDescription
Referenced from: /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServices.framework/Versions/A/OSServices
Expected in: /Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator3.1.3.sdk/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation

This only occurs when I have .ice files in my projects, everything else runs fine, so i was wondering if any of you had accountered this error before.

Thanks in advance,

Comments

  • l2succesl2succes Member Luc SuccesOrganization: NYU ACM student chapterProject: Robot iphone client
    Ok, I actually got it working on iphone simulator 2.2.1 but it crashes on any other version, 3.0 and up. I thought IceTouch 1.0 had support for the 3.0 sdk. Can someone confirm or attempt to run one of the examples on one of the newer iphone simulator versions.
  • benoitbenoit Rennes, FranceAdministrators, ZeroC Staff Benoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Hi,

    I can't reproduce this using the Ice Touch 1.0 Installer and using the 3.1.2 Simulator SDK. The chat demo works fine.

    Did you compile Ice Touch from sources?

    I do remember seeing this problem when compiling Ice Touch for the simulator using the 2.x simulator SDK and trying to run a simulator application compiled with the 3.x SDK. You need to build Ice Touch with the 3.x SDK to run Ice Touch applications with the 3.x simulator.

    Cheers,
    Benoit.
  • l2succesl2succes Member Luc SuccesOrganization: NYU ACM student chapterProject: Robot iphone client
    Hey thanks for the response,
    I tried thinking of what you said and I made sure to clean the build before trying to compile again, I also made sure that the Base SDK was set to iPhone Simulator 3.1.2 in the build target settings, so it compiles properly just as it did before but it keeps giving me that same error only when i set it to 3.x.
    Problem is I can't just use 2.2.1 because i added some 3.x sdk specific code and it doesn't compile anymore.

    I'd try running it on a physical iphone to see but i'm just starting iphone development so i haven't signed up for the license yet. What version of Xcode was IceTouch made for, maybe it has to do with that. im using Xcode 3.1.4, its the first version I use so I don't know if that could be the problem.
  • l2succesl2succes Member Luc SuccesOrganization: NYU ACM student chapterProject: Robot iphone client
    Hey gars, je voulais te demander,
    comment tu fais pour travailler pour un companie americaine de Rouen??
    moi jvis a New York mais chui ne a Paris, soit doit etre chaud! j'prefere Rouen n'empeche bien jouer lol. Mais bon, j'ai vraiment besoin de ton aide. j'utilise un server avec Ice-E dessus donc j'ai vraiment besoin d'utiliser Ice.
  • benoitbenoit Rennes, FranceAdministrators, ZeroC Staff Benoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Hi,

    I'm also using Xcode 3.1.4. You didn't specify how you installed Ice Touch. Did you install Ice Touch 1.0 with the installer or built it from source? I recommend using the installer if you didn't.

    Cheers,
    Benoit.
  • l2succesl2succes Member Luc SuccesOrganization: NYU ACM student chapterProject: Robot iphone client
    Oh yea sorry I forgot to mention that. Yes, I installed IceTouch using the installer, I never tried compiling it from the sources. I actually just attempted to start from scratch and reinstall everything including Xcode and this error just won't go away. I'm thinking about just using 2.2.1. Would you mind just taking a look at my project if I were to send it to you. It's only 11MB's just to see if you could run it on your end.
Sign In or Register to comment.