Compiling Ice v3.4.0 on OSX/Snow Leopard

jsgoeckejsgoecke Member Jason GoeckeOrganization: Voxeo LabsProject: http://tropo.com
I am trying to compile and install Ice on OSX and am getting this error:
===
c++ -c -I.. -I../../include -DSLICE_API_EXPORTS -g -Wall -D_REENTRANT MD5.cpp
c++ -c -I.. -I../../include -DSLICE_API_EXPORTS -g -Wall -D_REENTRANT MD5I.cpp
rm -f ../../lib/libSlice.3.4.0.dylib
c++ -dynamiclib -g -Wall -D_REENTRANT -L../../lib -o ../../lib/libSlice.3.4.0.dylib -install_name /opt/Ice-3.4/lib/libSlice.34.dylib Scanner.o ../Slice/Grammar.o Parser.o CPlusPlusUtil.o CsUtil.o JavaUtil.o Preprocessor.o Checksum.o PythonUtil.o DotNetNames.o RubyUtil.o PHPUtil.o Util.o FileTracker.o MD5.o MD5I.o -lIceUtil -lmcpp
ld: library not found for -lmcpp
collect2: ld returned 1 exit status
make[3]: *** [../../lib/libSlice.3.4.0.dylib] Error 1
make[2]: *** [all] Error 1
make[1]: *** [all] Error 1
make: *** [all] Error 1
===

Full log here:

https://gist.github.com/ae730fd23c0f1c3b5c10

Is there something I may do to get this compiled and installed on OSX? I am specifically hoping for the IceRuby support.

Comments

  • mesmes CaliforniaAdministrators, ZeroC Staff Mark SpruiellOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    Hi Jason,

    It appears that you have not installed MCPP, which is the C preprocessor library used by our Slice compilers. You can download an archive of Ice's third-party dependencies here. The README file in this archive provides build instructions, and don't forget to apply the MCPP patch.

    Note that we don't support Ice for Ruby on Mac OS X.

    Regards,
    Mark
  • jsgoeckejsgoecke Member Jason GoeckeOrganization: Voxeo LabsProject: http://tropo.com
    I had done a 'sudo port install mcpp', but it seems not to like that one. Will try a manual install.
Sign In or Register to comment.