This forum has been archived. Please start a new discussion on GitHub.

Can i config Glacier2 router multiple public ip ?

I have a question about glacier2,can i config multiple public IP (or DOMAIN NAME) to glacier?
What should I do?
Client end config:
test/router:ssl -p 4063 -h -p 4063 -h
(or use instead of the ip)
or glacier end config:
ssl -p 4063 -h -p 4063 -h


  • the mutiple ip were binded to the same computer.
  • We have a pcserver in intranet( for my company network rule, the network manager set a map on the company firewall that map 202.*.*.1 and 221.*.*.1 two internet IP for accessing from internet.
    so as the introduce in ice documnet. we config glacier as fowllows:
    Glacier2.Client.Endpoints=tcp -h 202.*.*.1 -p 4063
    Glacier2.Server.Endpoints=tcp -h
    but when i start the glacier,a exception take place
    C:\Documents and Settings\Administrator>glacier2router --Ice.Config=D:\
    !! 11/12/10 10:34:48.656 glacier2router: error: service caught unhandled excepti
    Network.cpp:1104: Ice::SocketException:
    socket exception: WSAEADDRNOTAVAIL
    how can we get the purpose:a internet pc access my application(or glacier) by the internet ip,and a intranet pc access my application(or glacier) by the intranet ip
  • benoit
    benoit Rennes, France

    Did you try just using the following?
    Glacier2.Client.Endpoints=ssl -p 4063 -h

    This should work if your company firewall is setup to redirect traffic on the public IPs to this address. I don't think you need to setup more than this for Glacier2. However, in general for servers which publish proxies, you typically also setup the PublishedEndpoints property, for example:
    MyServer.Endpoints=ssl -p 4063 -h
    MyServer.PublishedEndpoints=ssl -h 202.*.*.1 -p 4063 

    This isn't necessary for Glacier2 because it doesn't publish proxies. For more information on this, see 32.4.6 Endpoints.

  • I see. Thank you very much.