about chat demo

wangjunwangjun Member wangjun javaOrganization: victopProject: ERP Integration
hi,
when I change the port 4064 to 7001 in the config file config.glacier2router(chat demo config file), then I cought this exception:
!! 12/19/10 04:09:30.561 glacier2router: error: service caught unhandled excepti
on:
Network.cpp:1104: Ice::SocketException:
socket exception: WSAEADDRINUSE
why ?

Comments

  • xdmxdm La Coruña, SpainAdministrators, ZeroC Staff Jose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    socket exception: WSAEADDRINUSE

    That exception indicates that the address/port is already in use by other application.

    See the documentation of sockets error code from Microsoft:
    Windows Sockets Error Codes (Windows)
  • wangjunwangjun Member wangjun javaOrganization: victopProject: ERP Integration
    xdm wrote: »
    That exception indicates that the address/port is already in use by other application.

    See the documentation of sockets error code from Microsoft:
    Windows Sockets Error Codes (Windows)

    hi, xdm, thanks for your help.
    I try to change the port to another any number, but failed.
    It seems that the port must use 4064,
    why?
    so it's not the address/port is already in use by other application.
  • xdmxdm La Coruña, SpainAdministrators, ZeroC Staff Jose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    I try to change the port to another any number, but failed.

    Did you get the same exception with other port number? do you have a firewall running in that computer, if so try to disable the firewall to see if that helps.

    You can use netstat.exe to found if another process is listen on a port, see here
    How to determine which program uses or blocks specific transmission control protocol ports in Windows
    It seems that the port must use 4064, why?

    glacier2router can bind to any port, given that the port is not in use, the user has enough permissions and there isn't a firewall restriction.

    Note that if you change the port in "config.glacier2router", you will also need to update the push clients to connect to the new port.
  • wangjunwangjun Member wangjun javaOrganization: victopProject: ERP Integration
    xdm wrote: »
    Did you get the same exception with other port number? do you have a firewall running in that computer, if so try to disable the firewall to see if that helps.

    hi, xdm, Thanks a lot.
    yes, I got the same exception with any other port number, but 4064.
    I think the problem may be SSL.

    Glacier2.Client.Endpoints=ssl -p 7001 -t 10000 -h 127.0.0.1:tcp -p 7001 -t 10000 -h 127.0.0.1

    if I don't use ssl, the port number can use any other number.
    why?
  • xdmxdm La Coruña, SpainAdministrators, ZeroC Staff Jose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    Glacier2.Client.Endpoints=ssl -p 7001 -t 10000 -h 127.0.0.1:tcp -p 7001 -t 10000 -h 127.0.0.1 
    

    You cannot use the same port for SSL and TCP, you need two use different ports, for example try.
    Glacier2.Client.Endpoints=ssl -p 7001 -t 10000 -h 127.0.0.1:tcp -p 4502 -t 10000 -h 127.0.0.1 
    

    Note that if you want to use the Silverlight push client, the tcp port must be in the range 4502-4534, see the section ''Basics of the Security Policy System", in Network Security Access Restrictions in Silverlight
  • wangjunwangjun Member wangjun javaOrganization: victopProject: ERP Integration
    xdm wrote: »
    Glacier2.Client.Endpoints=ssl -p 7001 -t 10000 -h 127.0.0.1:tcp -p 7001 -t 10000 -h 127.0.0.1 
    

    You cannot use the same port for SSL and TCP, you need two use different ports, for example try.
    Glacier2.Client.Endpoints=ssl -p 7001 -t 10000 -h 127.0.0.1:tcp -p 4502 -t 10000 -h 127.0.0.1 
    

    Note that if you want to use the Silverlight push client, the tcp port must be in the range 4502-4534, see the section ''Basics of the Security Policy System", in Network Security Access Restrictions in Silverlight

    hi, xdm, thanks a lot,
    Let you laughed at this simple problem, It's ok now.
    I will take care.
Sign In or Register to comment.