icegridregistry cannot connect to assigned IP address

erikjerikj Member Erik JohanssonOrganization: National Solar ObservatoryProject: Advanced Technology Solar Telescope
Dear ZeroC support,

I am getting Ice::ConnectionRefusedExceptions when my client tries to connect. I have carefully researched the forum postings, which were quite helpful (e.g., set trace=2). I discovered that the server and client are using different IP addresses. The problem is that the icegridregistry tries to start up using the assigned IP address, which fails, and then ends up using the internal loopback address (127.0.0.1), which succeeds. The client then tries to connect using the assigned IP address, which fails because the server is using the loopback address. The client and server are both running on the same CPU.

I am running under Linux using Fedora 14, kernel 2.6.35.10-74.fc14.i686, Sun Java jdk 1.6.0_23-b05, and Ice 3.4.0-3.fc14.

I don't understand why the icegridregistry cannot connect using the assigned IP address. I have tried turning off both the firewall and SELinux, but I still get the same error. I have attached the output of the icegridregistry log.

Any help you can give me is greatly appreciated.

Regards,

Erik

Comments

  • benoitbenoit Rennes, FranceAdministrators, ZeroC Staff Benoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Hi,

    You should provide the configuration files of your client, server and IceGrid registry. It's not clear to me what exactly is the problem here. All I can see from the traces is that the IceGrid registry listens only on the loopback interface for it client/server/internal endpoints. I also recommend upgrading to the latest Ice 3.4.1 version.

    Cheers,
    Benoit.
  • erikjerikj Member Erik JohanssonOrganization: National Solar ObservatoryProject: Advanced Technology Solar Telescope
    icegridregistry cannot connect to assigned IP address

    Hi Benoit,

    Thanks very much for your reply. I am attaching my configuration file here. This is for my work laptop, so the hostname is different than in my previous posting (that was from my home machine), but the problem is the same.

    The problem is that the icegridregistry will not listen to the assigned IP address of the host. It only connects/listens to the loopback address. When I run my application, it tries to connect using the host IP address, so the connection gets refused. I don't understand why the icegridregistry does not listen to the assigned IP address. If I disconnect from the internet, then my hostname resolves to the loopback address and everything works fine.

    Thanks,

    Erik
  • bernardbernard Jupiter, FLAdministrators, ZeroC Staff Bernard NormierOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Hi Erik,

    A few recommendations that should help:

    - use IP address instead of DNS names like 'erikj-laptop' in your config file. It's possible that erikj-laptop resolves to 127.0.0.1 on your laptop, and another IP on other hosts. May as well remove these potential DNS resolution issues by using IP addresses, at least until you get it to work.

    - make sure there is no firewall running on your icegridregistry host, or if there is one, that port 11,000 is open.

    - do _not_ put all your Ice configurations in a single file. Your IceGrid registry config should be in a file, your IceStorm config in another file, etc. Merging these files together can introduce hard-to-track problems, e.g. you may not realize but IceGrid is itself using its own IceStorm.

    All the best,
    Bernard
  • erikjerikj Member Erik JohanssonOrganization: National Solar ObservatoryProject: Advanced Technology Solar Telescope
    icegridregistry cannot connect to assigned IP address

    Hi Bernard,

    Thank you for your reply. I just ran a quick test using a hard-coded IP address in my configuration file and everything seems to work fine. When I start up the icegridregistry it now binds to the assigned address instead of the loopback address. I now need to do some digging to see why it fails when I use the hostname in the config file.

    Many thanks for your help!

    Erik
Sign In or Register to comment.