Home Bug Reports

VS Plugin crashes

kwaclawkwaclaw Oshawa, CanadaMember Karl WaclawekOrganization: Personal
I installed the newest version (3.4.1.2) of the plug-in in VS 2010.
Occasionally, when debugging a project, stepping through the code, the plug-in crashes with an IndexoutOfRangeException.

Unfortunately, I cannot reproduce this reliably.
The project is not an ICE project, so this is not a Slice compilation issue.

I have attached a screen capture of the error dialog.

Comments

  • xdmxdm La Coruña, SpainAdministrators, ZeroC Staff Jose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    Hi Karl,

    Thanks for report the problem, we will fix this for the next release.

    Jose
  • xdmxdm La Coruña, SpainAdministrators, ZeroC Staff Jose Gutierrez de la ConchaOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    I was able to reproduce the issue, the add-in has a bug in the method that is used to retrieve the active project.

    The bug is easy to reproduce by selecting the solution object, and then click Debug Start. As workaround select the project or one of the project files before click Debug Start.

    A fix for this issue will be included in the next add-in release.

    Thanks again for the bug report,
    Jose
  • GravitasGravitas Member Shane TolmieOrganization: Software HouseProject: Server modules in C++, C# and Java, to client. ✭✭
    I can also verify that I'm running into this same problem on Visual Studio 2010, SP1, with the latest version of ICE as of 2011-04-05.
Sign In or Register to comment.