Does ICE 3.3.1 support version 5.2.5 or 5.3 of PHP on RHEL 5 64 bit?

tinattinat Member Tina TsuiOrganization: Vanderbilt University Medical CenterProject: Collaborative platform for Imaging Mass Spec
Hi all,

I'm using the latest version of OMERO which requires Ice 3.3.1 I also would like to integrate with another PHP component that requires version 5.2.5 or later on the same server running RHEL 5.x (x86_64). Your document lists 5.1.6 as the supported version of PHP. I'm wondering if PHP 5.2.5 or 5.3 is compatible with Ice 3.3.1 on RHEL 5.

Thanks!
Tina

Comments

  • mesmes CaliforniaAdministrators, ZeroC Staff Mark SpruiellOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    Hi Tina,

    Welcome to the forum.

    Our PHP extension in Ice 3.3.1 should work with PHP 5.2.x. You will need to download the Ice 3.3.1 source distribution and compile the extension yourself. In order to build the source distribution, you will also need to install our mcpp-devel RPM.

    It's not necessary to build the entire source distribution. Here's all you really need to do:

    % tar xzf Ice-3.3.1.tar.gz
    % cd Ice-3.3.1/cpp/src/IceUtil
    % make
    % cd ../Slice
    % make
    % cd ../slice2cpp
    % make
    % cd ../Ice
    % make
    % cd ../../../php
    % make

    This assumes that PHP 5.2.x is installed in the default location. If it's installed somewhere else, set PHP_HOME to the installation directory.

    I quickly tried this on CentOS 5.5 (x86) with PHP 5.2.10 (from the CentOS Testing repo) and everything worked as expected (including the test suite).

    Note that the PHP extension from Ice 3.3.1 will not compile against PHP 5.3.x.

    See the file Ice-3.3.1/php/INSTALL for more details on building a source distribution.

    Regards,
    Mark
  • tinattinat Member Tina TsuiOrganization: Vanderbilt University Medical CenterProject: Collaborative platform for Imaging Mass Spec
    Thanks Mark!
Sign In or Register to comment.